Octopi won't connect to creator pro


#1

Hello,

I got a creator pro running sailfish a few days ago and have been trying to configure it with my raspi 3 octopi, which I had working for my monoprice select mini V2. The problem is that it just won't connect. I've tried selecting the baudrates individually, increasing the timeout, 3 different USB cables, running it in safe mode, and sacrificing a goat.

lsusb does recognize some kind of connected device, and sometimes the printer will play its little music and flash the firmware version as I try to connect, but it doesn't actually do so.

Any help would be greatly appreciated, thank you.


#2

Have you tried the GPX plugin?


#3

Hey, thanks for the reply. I have tried the plugin to no avail. Though I was under the impression it was just involved in converting the gcode (not communicating with the printer?).


#4

In the context of OctoPrint it "translates" the communication protocol and files on the fly. If you have a sailfish based printer, you'll definitely need that plugin, but it might need some work to get it to talk correctly with your printer.

Maybe @markwal has any hints, or a google search for your printer in combination with OctoPrint might help.


#5

Okay, thanks. I'll definitely make sure to keep that activated while I try more things.

Every link I can find on this topic is purple, unfortunately.


#6

Just an update. There was an update of the GPX plugin and now it works! Celebration!


#7

Mark this discovery as the solution then please :wink: