Octopi wont connect to ender

What is the problem?

Everything was working fine and then it stopped connecting to the printer

What did you already try to solve it?

I've tried five new cables, a fresh install of Octopi..

Have you tried running in safe mode?

octoprint-systeminfo-20230507194312.zip (29.1 KB)
octoprint-systeminfo-20230507194312.zip (29.1 KB)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230507194312.zip (29.1 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Pretty simple setup. Ender 3 neo with 4.2.2 MB, raspberry pi which connects to network just fine, swapped cable to all 4 usb ports. I know nothing about code so please come up with a simple solution if there is one. Thanks in advance

Is a serial device listed in the device manager (Windows Key + X)?

Wait you say you're running it on a pi? The systeminfo bundle says you're using a pc and windows!?

Octoprint is on my desktop but the printer is connected to a pi3+B. the wifi connection between the pc and Pi is fine. I checked device manager and aside from one USB 3 showing an issue there isnt any related serial device listed.

That sounds like a really weird setup. How do you want to connect the printer to the windows pc then? I mean there are ways like usbip, but I wouldn't really recommend that.
You're aware that OctoPrint is a host software and runs on the host and not on the client, right?
You should flash OctoPi to the Pi (which you said you did), then enter http://octopi / http://octopi.local or http://ip-of-the-pi in your browsers address bar and control the host from here.

[PrintedWeezl] thats what i have. Just loaded a fresh copy of octopi on my Pi3+B and loaded a fresh flash to the ender 3 Neo. I have Octoprint running on my desktop and have no problem connecting to the Pi from my desktop. My webcam is connecting just fine I just lost the ability to connect from Octoprint to the printer. Swapped out 5 different cables( all new) and swapped usb ports on the PI and I still get ths:
thumbnail (4)
I've also uninstalled Octoprint and reinstalled it will all defaults, tried all baud rates and still cant get back to where I was a few days ago when all was running smoothly. Really appreciate you taking the time to help a dumb ol man

How do you manage that?

Or do you mean the Web GUI of OctoPrint with the latter one?

For clarification:

OctoPi consists of two parts:

  • A operating system
  • And the OctoPrint 3D print server

I guess its running off the wb. I'm getting the "could not auto detect the printer error" aside from starting all over with new hardware and software I'm lost

We're looking into that soon. The only thing we both are trying to understand is why you installed OctoPrint on your desktop.

1 Like

lol. I'm an ol man and my desktop is on the top floor of my house and the printer is in the basement. With octoprint on the desktop I was able to d/l, slice and send my file to the printer and didnt have to run up and down stairs!

You don't need OctoPrint installed on your desktop, which is where your systeminfo bundle from above has come from.

The OctoPrint server should be installed on your Pi, connected to the printer, and then you access it via your network using the Pi's IP address/hostname in the browser. Your systeminfo bundle has not come from an RPi.

It sounds like you might have OctoPrint installed twice, on both the Pi and PC, but you don't want the second one. The PC install of course can't connect to the printer because it doesn't have one connected physically, it's downstairs in the basement.

Try and uninstall OctoPrint from your PC (however you managed that) and access your Raspberry Pi's IP. If you get into OctoPrint on there, try connecting to the printer and if it doesn't work share a new systeminfo bundle from there.

I owe you a cold one!!!!!! That worked. Not sure what changed from the initial set up but an back up and running. Thank you so much!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.