Octoprint 0.18.0 installation on ssd, pi4 4gb

What is the problem?

I try to install Octoprint on the ssd, this one starts, but the boot does not finish. Photograph attached
(Sorry in advance for the mistakes, I go through a translator, I am French)
PS: I tried again, it makes me the same by adding: Cannot open access to console, the root account is locked.

What did you already try to solve it?

I tried with the most recent version in nightlies, but the problem remains the same

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 0.18.0

Seems like the pi was unable to find the boot partition

how did you flash the image on your ssd?
maybe you just flashed the system partition? tbh I don't know how far a pi 4 would boot in that case ^^ a pi 3 wouldn't boot at all

also your bootloader could be outdated.
in that case boot a "normal" raspbian (pi os) image via sd card and try this:

Manual bootloader update

From a Raspberry Pi OS 2020-08-20 or newer SD card:

sudo apt update
sudo apt full-upgrade

Edit the rpi-eeprom-update file and changed the "critical" value for the FIRMWARE_RELEASE_STATUS option to "stable" , using sudo nano /etc/default/rpi-eeprom-update

# Install with the factory default configuration (-d).
sudo rpi-eeprom-update -a -d

source and source

Good evening, thank you for your answer, I had already done this step, but I will try again times when I did it wrong the first time.
Otherwise I flash with BalenaEtcher

I also tried it with etcher an hour ago with an thumbdrive. Worked for me :man_shrugging:
Sometimes etcher is a bit... difficult - you could try the raspberry imager tool
It seems to support usb devices. Just select own image in the image selection screen

Indeed, works well on usb key, I test as you told me and keep you informed, thank you very much

:sob:Unfortunately, the result is the same. I don't understand why it works on a usb key and not on my ssd

How large is your SSD? Are you connecting to the USB 3.0 port? What type of SATA adapter are you using? There are reports that not all sata adapters are compatible.
I would try a regular raspian image, if that doesn't work, you know it's not Octoprint.
I feel for you though. What etchers progress window go up over and over and over is a PITA! Good luck!

Hello, I tried with a Kingston 240 GB ssd A400 ans a crutial bx500 with a case Zheino USB 3.0.

Which name does the device manager on windows show for the controller?
I also got a few sata to usb adapters - maybe I got one with the same controller

I have to confess that I don't know how to look at this. But in the disk property, it indicates USB SCSI DISK DEVICE

Good evening, back to the news. Strange thing, with the same manipulations on my rp3b I manage to boot on the ssd in usb ... So I really do not understand why it does not work on the rp4b

Pi4 works differently to the Pi3 - it has a flash EEPROM installed that performs the boot process. You'll need to look at instructions specific to the Pi 4.

Last I checked, it went along the lines of install to SD card, update the bootloader, set the correct settings to boot from USB in this bootloader, then flash the image to your USB storage device.

OctoPi 0.17 will not work, you must use th 0.18 release candidate. This is the only OctoPi image that will work.

Problem found. I came across a video where the person had the same problem talking about power, so I tried an old adapter with external power and it works. I am amazed that the usb3 port does not deliver more power. I will therefore have to change the adapter for a more recent one in usb3 with external power supply I think :frowning:

Well, it could also be the adapter itself and not a power problem. But also remember that the Pi is only getting 3A at 5v. If your USB device needs 1A at 5v, there wouldn't be enough left over for the Pi to do it's thing. Add a camera into the mix and you're talking even less power. In general, unless it's a low-powered device (USB RF keyboard dongle or USB flash drive) the suggestion on the Pi forums is to always use a device with independent power or a hub with it's own power source. That's why it's so important to make sure that you are not trying to power your printer's USB-UART adapter the the power from the Pi. You'll quickly start to run out of juice.

Okay. I tried with the power supply from the adapter, but the raspberry fan remains powered. So I ordered another USB 3.0 adapter with UASP with a ssd m.2 2280. I saw this on a other forum where the person was using it to overcome this concern

I feel your pain. I had that issue where I was powering my old PI from my cable box and then ran into this issue because I plugged something else into it and it would randomly freeze. I wanted to reply so if anybody else sees this it will save them a ton of head scratching. Make sure you have enough power!! Switch power bricks, cables, etc, etc, etc ... wild but such happens.