Octoprint 1.3.10 - Strange behaviour after G29


#1

What is the problem?
I just installed Octoprint 1.3.10, running on OctoPi 0.16.0. Using gcode already in the upload folder (A Temp tower, already printed successfully) I started the same print again after having set up my PID values, and found that immediately after my ABL command (G29) had completed my CR-10 received commands to set both bed and nozzle temps to 0
What did you already try to solve it?
I confirmed by looking at the terminal windows that it was Octoprint that was sending these commands I again set the temps from the control panel of the CR-10 and, when up to temperature, ran the G29 command from the Octoprint interface. Again I verified that Octoprint sent commands to zero these temps. The terminal window section is shown below.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
The Section of the terminal windows showing the end of the bed leveling process and these temp commands is copied below.
Recv: T:220.00 /220.00 B:60.15 /60.00 @:64 B@:0
Recv: T:220.00 /220.00 B:60.00 /60.00 @:64 B@:0
Recv: T:220.00 /220.00 B:59.98 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.01 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.16 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.16 /60.00 @:64 B@:0
Recv: T:220.00 /220.00 B:60.01 /60.00 @:64 B@:0
Recv: T:220.00 /220.00 B:59.94 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.00 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.16 /60.00 @:64 B@:127
Recv: T:220.00 /220.00 B:60.16 /60.00 @:64 B@:0
Recv: Bilinear Leveling Grid:
Recv: 0 1 2 3
Recv: 0 -0.290 -0.135 -0.037 +0.150
Recv: 1 -0.165 -0.077 -0.075 +0.048
Recv: 2 -0.033 +0.007 -0.057 -0.007
Recv: 3 +0.175 +0.183 +0.040 -0.053
Recv:
Recv: X:294.00 Y:260.00 Z:12.73 E:0.00 Count X:23520 Y:20800 Z:5036
Recv: ok
Send: M140 S0
Recv: ok
Send: M104 S0

This only happened after the upgrade to OctoPrint 1.3.10, done from the Octoprint interface after receiving the prompt to upgrade to this new stable code level.
To mitigate this problem I have added temp setting commands into my starting gcode in S3D.


#2

Hi @Al_Wilson,

a quick board search gave this result: https://discourse.octoprint.org/t/target-heater-temperature-is-reset-to-zero-right-before-printing-starts-after-g29-and-g28/6867


#3

Hi,

Clearly I searched for the wrong thing. However, many thanks for pointing me in the right direction. As far as I recall I never even installed this plugin but I see the relevant option so thanks – I will disable cooldown after probing.

Al Wilson