Octoprint 1.4.2 Icons Missing in Header

What is the problem?

I upgraded to Octoprint 1.4.2 a few days ago. and the icons; setting, power, etc are missing from the Blue header.

I am running the 0.15 image on a Rpi 3B. This setup has worked for > 6 months with octoprint 1.3. I am viewing with Google Chrome on a MacBook Pro with 10.14.6 Mojave.

What did you already try to solve it?

I tried Safari and Firefox and saw the same missing icons.
Via SSH, I restarted Octoprint in Safe mode and observed the same symptoms.

Complete Logs

octoprint.log (88.3 KB)

plugin_pluginmanager_console.log (11.4 KB)

WRITE HEREserial.log.zip (989.5 KB)

Additional information about your setup

OctoPrint version: 1.4.2
OctoPi version: 0.17
Rasberry Pi 3B
printer: Monoprice MSP
firmware ADVi3 4.0.6
browser: Chrome, Safari, & Firefox,
operating system Mac OSx 10.14.6 Mojave
Computer MacBook Pro 2015, i7, 16GB RAM, 1TB SSD

SCREEN Shots Showng empty header.



... as much data as possible

try scrolling to the right
I bet they're hiding!

Thanks, but they're not there either. I tried above and below too. :wink:

Could it be that the user you are logged in as simply does not have the rights to access the settings or restart OctoPrint?

I am logged in as "pi"

UPDATE
I downgraded to Octoprint 1.3.12 and the icons have returned. I did not change my login or my browser.

In OctoPrint 1.4.0 a new granular permission system was introduced - that's why you don't see this on earlier versions.

When you are on OctoPrint 1.4.0+, you can go to access control in the settings, and see what permissions each user has. It seems you are logged in with a user that doesn't have full admin rights.

You say you are logged in as Pi, however that means nothing other than the name of the user - it's completely separate to the Raspberry Pi's users. Were you the person who set the install up? If not, you'll have to ask the person who did, to sort it out for you.

1 Like

Thanks for the reply Charley.
I own the Raspberry Pi and I upgraded from 1.3.12 to 1.4.2.
I fixed it by going back to 1.3.12, setting a new password for the normal user. I then upgraded to 1.4.2 and used the normal user and new password to login. It works fine now.

Thanks.