Octoprint 1.5.2 Error: No more candidates to test, and no working port/baudrate combination detected

What is the problem?

Initially was working with my 1st time booting up. After I update to the latest stable update. It is unable to detect my printer. Camera stream still working normally, Port is set to auto and baud rate are set to 115200. My printer is Ender-3. An error keep saying :

State: Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?

Not sure where to start, still new to Octoprint.

Have you tried running in safe mode?

I tried in safe mode but still remain the same issue.

Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 1 port/baudrate candidates: /dev/ttyUSB0@115200
Trying port /dev/ttyUSB0, baudrate 115200
Connecting to port /dev/ttyUSB0, baudrate 115200
Unexpected error while connecting to serial port /dev/ttyUSB0, baudrate 115200 from hook default: SerialException: '[Errno 5] could not open port /dev/ttyUSB0: [Errno 5] Input/output error: '/dev/ttyUSB0'' @ comm.py:_open_serial:3670
Could not open port /dev/ttyUSB0, baudrate 115200, skipping
Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am using Raspberry Pi 4 Model B 2GB, Ender-3, Octoprint1.5.2.


The problem was solved by just replacing the MiniUSB cable to my Ender-3


Hello @wongzhiwei1!

Great you found it.

So could you please:

This worked for me as well!

1 Like

Just out of curiosity because I am running into the same issue as of right now. Does it matter if the cable is a USB 2.0 or 3.0? Curious because I can only find 3.0 cables in a few places but am wondering if a newer 2.0 cable would work.

Hello @iWater !

A USB 3 cable has the same connectivity features as an USB 2 cable plus the features for USB 3.
In all, the quality of connection depends on the quality and length of the cable.
But usually, a USB 3 cable as a USB 3 connector on one end or both. You may can connect it to the Pi, but not to the printer.
As there are bad USB 2 cables, there are also bad USB 3 cables.

Thanks for reaching out!
Just want to mention I'm running a zero w which isn't officially supported but has worked before. I've got everything connected except for permissions to the serial port I believe. Right now, it seems the error I'm running into is upon trying to connect via octoprint is that I'm not granted permissions to connect. Do we know a workaround?

Might be easier for you to open a new thread, since we can't actually tell what you have installed, what the error is, and what you have already tried. 'Not granted permissions' has many solutions, but it depends what you are actually using.

True true! I'll get to that asap!

Thanks, it worked for me too, funny how we always look for the more complicated fix first lol

1 Like

Successful solution for me too. :slight_smile:

1 Like

Here's another confirmation that trying a different cable corrected the issue.

I was using the mini-usb cable that came with my BigTreeTech SKR E3 Turbo. grrrr


I know the solution for this issue was replacing cable but just want to add this because what worked for me for this issue was something different.

I upgraded from Python 2 to Python 3 based on messages in OctoPi/OctoPrint UI and after I did this upgrade (following the instructions provided), my printer no longer connected. I tried couple different things including reimaging the SD on my Raspberry Pi to the lastest version but still my printer wouldn't connect. Installing GPX plugin fixed it so if you're having this issue I'd suggest reinstalling that plugin.

I had the same problem. I tried the cable swap but it didn't work. It turned out to be a connector for the my ABL sensor was loose and caused this intermittent error.

I too was having the same problem. Everything had been working fine with my internal connection to my CR10S Smart. Yesterday I added some lights to my machine and the USB was running side by side to the lighting wire. I rerouted the USB so it was clear of any possible interference and my Octoprint worked perfectly again. I have proved this as an issue by putting the cable near the lights again and I then get the error message, remove it and error message disappears :slight_smile:

1 Like

Thanks. Worked for me also. I tried a brand new cable :frowning_face: and it caused the problem.

how can you rerouted the usb cable?, i'm having same problem