Octoprint 1.9.2 failed to start on RPi. New install

Fresh install of PiOS Bookworm on Raspberry PI Zero 2.
What it means ?
"Could not initialize settings manager: Argument 'bases' has incorrect type (expected list, got tuple)
There was a fatal error initializing the platform."

Cannot run it at all (safe mode, debug, etc.).
Cannot obtain systeminfo (there is no systeminfo bundle).

Have you tried running in safe mode?

Yes i try

Did running in safe mode solve the problem?


Systeminfo Bundle

What sysytem bundle ??? Octoprint wont start. Even with system info

Additional information about your setup

OctoPrint 1.9.2 Raspberry Pi Zero 2 with fresh install of PiOS Bookworm Python 3.11

Hello @Krzysztof_Silesia !

Are you sure this includes OctoPrint?

Usually you use an OctoPi image to start.

Looks like bookworm issue. Back to bullseye, and works.

1 Like

Downgrading pydantic to version 1.10.9 fixed the same problem for me. It looks like pydantic has the same issue in other projects.

1 Like

I tried downgrading to 1.10.9 and still the same error.
How did you perform this downgrade?

Downgraded octoprint to 1.8.6 and it works now.
weird bug

@Mikhail_Ryzhov answer worked for me. I ran pip install --force-reinstall -v "pydantic==1.10.9" in my Octoprint virtualenv. I am on Raspbian Buster.

for me on octopi image 0.18 i had to run the pip command from oprint folder. this solved it as well for me. hopefully this bug is fixed soon

I can confirm downgrading pydantic to 1.10.9 worked for me as well on this issue.

Running on Raspbian Buster.

Best regards,

pip install --force-reinstall -v "pydantic==1.10.9"

T̶h̶i̶s̶ ̶d̶i̶d̶ ̶̶̶n̶o̶t̶̶̶ ̶w̶o̶r̶k̶ ̶f̶o̶r̶ ̶m̶e̶.̶

Edit: Wrong steps followed. Follow the following official steps

thank you jneilliii

did you do it from within the oprint folder virtual environment? We've found that it's version 1.10.13 of pydantic that broke, and released this announcement on the exact steps to fix.

1 Like

I missed the virtual environment step. My apologies. I followed the instructions on the announcement and it's back up again. Thank you!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.