Octoprint admin lost

What is the problem?

I dont have admin rights on my octoprint account so i cant access settings or anything

What did you already try to solve it?

nothing cant find anything about it

Have you tried running in safe mode?

no dont know how to

Did running in safe mode solve the problem?

havent tried

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

probably why i cant find any solution is because im running a virtual enviroment in python to host an octoprint server rather than using an octipi i run this server on my windows 10 laptop

[SOLVED] Fixed it by removing users.yaml aswell as changing first start to true in config

Open the file in %APPDATA%\OctoPrint\users.yaml and check you don't have more than user configured. If you don't, add admin to the list of roles.

so i did what you said and added admin to the list of roles in users.yaml and then restarted the server yet i can still not see the settings tab

Actually, it may be under groups that you want it, not roles. Not sure which would give you access to the settings entirely.

This is what mine looks like:

  active: true
  apikey: null
  - users
  - admins
  password: ...

Also, try and run in safe mode incase a plugin has broken the settings buttons/icons and it's not a permissions issue.

Hey, Thank you for the help it worked, I solved it by changing first time to true in config aswell as removing the users.yaml