Octoprint and Chrome

What is the problem?

I get an intermittent beep tone while using octoprint from the Chrome web browser. It occurs as long as I am connected to octoprint and I can find no setting to disable it either within octoprint or in Chrome. Is this an error beep or a keep alive tone - and what can I do to turn it off?

What did you already try to solve it?

Examined all available settings I could find in the octoprint web interface with no setting being obvious to associate with beep tones or other notifications.

Have you tried running in safe mode?

Are you saying that octoprint has a safe mode? I just installed octoprint two days ago on a Raspberry pi 4 B - and it works great. But the beep tone comes from the PC running a web browser, not from the pi computer.

Did running in safe mode solve the problem?

Untried since it is unclear what "safe" mode you are referring to, on the raspberry pi or on the pc running the web connection.
octoprint-systeminfo-20210714112410.zip (4.1 KB)

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup



safe mode means: all plugins disabled. That helps distinguishing between octoprint core functions and effects of all sorts of 3rd-party software. You can enable it from the system menu and it's a useful test. Doesn't take long, basically 2 restarts of octoprint and your test on the issue you have. (A much better description comes when you just click on the link in your own post...)

OK - the only plugins are the bundled ones for Anonymous usage, Action Command Prompt support, and Application Keys plugin. No 3rd party - only installed octoprint two days ago. I thought for a moment I had solved it using an option to filter out messages whose severity was "Info" but whatever is generating these beeps just chose not to beep for a few minutes before resuming.
So under what circumstances will octoprint issue a beep to alert the user to a problem? I suspect it's some check for being alive or perhaps an unset temperature setting that's triggering an alarm - but I find no messages to support that and the two jobs run so far have had no issues other than the beep tones annoying me

So did you try it after Restart OctoPrint in safe mode? There's no point in reasoning, it's simply an accepted first step in excluding possible culprits.

So under what circumstances will octoprint issue a beep

No idea, it never beeped on me using firefox, chromium, brave or waterfox. Others may chime in and correct me but I assume what you have is an effect quite specific for your setup. Right now it can be any of a bazillion reasons and the process is to exclude more and more of the suspects until we are left with the one that did it.

I haven't ever heard of OctoPrint causing the client device to start beeping. That's a really weird issue. There's no code in OctoPrint's source to beep to do anything, so this is definitely not one we've seen before

Safe mode in this case would not make much difference - since there's nothing 3rd party to be disabled.

How often does it occur? Do you have any extensions installed? Opening OctoPrint in 'incognito' mode will prevent extensions from running, so you could test it there.

I wouldn't even know how to make it do that to be honest, intentionally or unintentionally.

OK - as a few have said, it does appear to be something not related to octoprint - not sure what it is yet - but when I came down this morning to use my computer where octoprint and the printer had been off overnight, I got a few of those same bleeps - and they continue to be intermittent and not relatable directly to octoprint. So now I get to track down the source somewhere on my 7 year old high performance system. All I know at the moment is that I didn't have the problem before I switched to octoprint - but that's looking like pure coincidence at the moment. So my apologies for thinking it was octoprint - which so far has performed perfectly. Please forgive me for what turns out to be a false accusation but history tells me when behavior changes it is related to the last change you made, and talking to octoprint through my main browser was the only recent change. Except for Windows updates - wouldn't that be a surprise (to no one) if a Windows 10 update turned out to be the real cause!!! If I ever figure it out - which I haven't so far - I'll report it - and I currently can't find a sound anywhere like it in the windows normal wav file locations.
OK - the final solution!!! I tracked it down to the Discord App which I think I enabled the same day I got octoprint. I'd been on Discord intermittently for a few years for mod support for a game I've played for years, Fallout 4, with its myriad mods. But I hadn't used the Discord app which I found many users recommending as a quick way to get 3D printing help. So I went to the Microsoft store and got the Discord App - and should have been paying more attention to the options it had for install - it enabled itself to start when Windows starts and defaulted to a bunch of message notifications. And since I was on Discord for several gaming mod authors, anytime anyone posted something in one of the 3 or 4 gaming sites, let alone the Sovol SV01 printer and 1 or 2 other 3D printing sites, I got a ping from the Discord App. Another lesson re-learned - check an apps default features before you blindly let it take over your machine.

1 Like

What, exactly, is beeping? The computer running Chrome? The device running OctoPrint? Or your printer (what model/firmware)?

This seems to indicate the computer running Chrome, but it might be the computer running OctoPrint. If the computer is 7 years old, it might be a hard drive aging and beeping to warn of an impending failure... It starting to make noise after starting to use OctoPrint might just be a coincidence... (Granted, I'm troubleshooting in the dark here...)