Octoprint and Geeetech Smartto firmware

What is the problem?

Only affects my Geeetech Smartto based printers, marlin works great.

While I can send print jobs to the printer, I can’t pause/resume the print, the resume button never shows up.

I also can’t cancel a print completely. If I try, octoprint sticks at ‘cancelling’ and the printer stops moving. It never cools down, and octoprint never recovers. I have to power cycle the pi.

What did you already try to solve it?

Tried multiple times and the problem persists. I would assume that it has something to do with octoprint waiting for a reply the the smartto isn’t sending.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

I can include a log later tonight.

Thanks in advance guys/gals!

1 Like

Start a small print, go to the Terminal tab and select the checkboxes to make the output quiter (no temperature messages, for example)...

...and Pause the print.

At this point, do a screen capture of what just shows up on the Terminal. Did OctoPrint send something to the printer? Did it respond and how? If there's too much going on, then copy that information (there's a button there) and show us what happened at the moment of truth.

Next, show us what's going on in the JavaScript console. In Safari, I right-mouse click and choose Inspect, then click the console tab in the developer's window. It's important to know if there are JavaScript errors. They can point you in the right direction. Often, these errors are caused by your plugins.

That said, try all this in Safe Mode from the System menu. If it works great from there, then it's one of your plugins doing this to you.

I don’t think it’s a java problem. It works fine on all of my Marlin based printers. I would assume it has something to do with the Smartto firmware from Geeetech. I’ll post a log of the pause as you suggested later this afternoon.

For the pause button to change to resume, does octoprint wait for a reply from the printer? Like a confirmation code that it has paused?


Java? I think I mentioned JavaScript there in my suggestion.

Please do the reproduction and share the contents of the terminal tab as suggested. It sounds like your printer's firmware is misbehaving in such a way that causes OctoPrint to get stuck in pausing/cancelling mode.

Also state your OctoPrint and OctoPi versions and share logs.

Have you solved the problem .. because I have the same concern .. Geeetech A30T (Smartto and octoprint 0.17.0)
Thank you

Need help? Read this first! Remember to provide version numbers, relevant log files and general information about your setup. Problem solved? Mark the solution! WE NEED LOGS TO HELP YOU!

@manu68, you have opened a two year old thread with no posted solution most likely because the original poster never provided the requested information. If you want our help, you will need to provide the information requested. The more information you provide, the better our chances of supplying the help you need.

1 Like

ok i will do the requested tests ... and come back here to post them.
Thank you