Octoprint and PI 3 B+ complete newbie wifi issues


#1

What is the problem?
I just received a brand new Raspberry Pi 3 B+ and Rpi camera that I want to setup Octoprint on for my Prusa Mk3. My Pi connection to my local network is fine over ethernet but I cannot get the wifi to work.

What did you already try to solve it?
I downloaded the latest stable build and followed the instructions to get wifi working. Used Etcher (I have a Mac) to flash the image to microsd. Transferred the card to my Pi only to have it not connect to my network. I originally used a wrong text editor so I re-flashed the card and used my windows emulator to run Notepad+ to edit the network text file. I updated my ssid and password along with the country code (US) and "#" in front of the default "GB". Reinserted into Pi, booted - no connection.

Connected Pi via ethernet and instant connection to octoprint. I can see the camera live and everything seems fine. Disconnect ethernet and reboot - no wifi connection. I then tried to download the latest nightly build, did the same steps - no wifi connection but ethernet connects just fine.

This is my first foray into Raspberry Pi so I have no real idea how to remotely connect to it or query it or do any command line steps. I am wondering if there is something that I did not install correctly because there are sites that re saying that I should SSH in and change a file in a etc/ folder but I cannnot find a folder like that. I also found a few people talking about running sudo raspi-config to manually update things like wifi information and time code / country code, but I have not been able to try that yet. I think the very first install I did, I forgot to comment out the default country code while uncommenting my country code - but I have done a re-install since then with the same issue even though I have ensured I made those network changes before booting up.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I have tried both 0.15.1 and also latest nightly build. Since I am so new to the Raspberry Pi, I am not sure what else I can provide for reference to get help on this. If there are log files or something that I can generate and provide - if anyone can provide some beginnner instructions on how to get those / post those here, I can do that tonight when I get home.


#2

If you're willing to try a new tool that I wrote earlier this week, here's a raspi-troubleshooter that might help introduce you to some of the troubleshooting tasks and commands involved.


#3

@OutsourcedGuru's troubleshooter is an excellent document with lots of good information.

I believe the most important next step for you is to get SSH working.

Missing from the troubleshooter are instructions for downloading an image, flashing the SD card, and how to edit the files in the /boot partition on various operating systems (Linux, Windows, and MacOS) but it appears you've got that covered.

You mentioned Notepad+ and the recommended Windows editor is Notepad++. The key is to make sure that on the bottom right of the window the line endings are set to Unix (LF). Right-click on the status to set it. The other choices are Windows (CR LF) and Mac (CR) neither of which will work.

The other common mistake (at least it was my initial mistake) is not getting all the "#" comment characters removed. You could post a copy of your octopi-wpa-supplicant.txt file (be sure to enclose it preformatted text, ``` symbols).

The 15.1 OctoPi image is working for me on my RPi 3B+. I don't think you need any other images.


#4

So I have been messing around with this for awhile now - back and forth. I started off with reinstalling the 0.15.1 image only to have nothing connect - wireless or ethernet. Tried multiple times with no result. Went back to the nightly build 0.16 and it would not connect either. Messed with the network octopi-wpa-supplicant.txt file making sure that I was in Notepad++ using Unix and tried different settings based on google searches - nothing. Finally got it to boot via ethernet and I was able to run raps-config via SSH. I found a few interesting things out there. (1) When I clicked on network settings it said there was no wireless device found. (2) When I went into the localization, it was still setup for GB instead of US. (3) When I first connected I got this long error about ECDSA and host files and it might be an attack or some crazy stuff.
So I wen through and updated the localization to be US and updated my time zone information. I rebooted and disconnected the ethernet. It has been several minutes and I still cannot remote in through SSH or browser trying both the IP address and the octopi.local - nothing connects.

Here is how I have the octopi-wpa-supplicant.txt file setup

## WPA/WPA2 secured
network={
  ssid="superawesomewifi"
  psk="supersecretpassword"
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

## WEP "secured"
##
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0
#}

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

I even went in and tried to rearrange the information but it did nothing.

I have it now setup where I can log into Octopi if I am connected via ethernet. When I connect via SSH, I run raps-config and go into network settings and it tells me there is no wireless interface found. I ran the rip update which downloaded some new things. Rebooted with the ethernet disconnected and still nothing. But if I go and shut it down, install the ethernet cable and then bring it back up - no problem.

I tried some SSH code I found to see if I could get the network information but I must not have the right SSH code - I got nothing back. Any assistance from here would be greatly appreciated - SSH code or logs or anything.

Thanks in advance


#5

Well - here is where I apologize and say I learned a valuable lesson regarding all the various raspberry pi models. My model I received is a 3 B+ - and as far as I knew, the 3B+ all have wireless on board. As I read the box, it caught my attention that it says "Pi 1" on it - so I went to the OEM website and done some digging. Turns out I got the one with OUT wireless on board. So no matter what I do, I don't think I will have any luck getting wireless working on this one. Lesson learned and I did get some valuable learning on accessing and setting up a raspberry pi - so that is something. So thank you everyone - I apologize for wasting your time on a goose chase. I am going to exchange this model for the wireless one and start over again. Hopefully that will go better.