Octoprint behaving strangely

What is the problem?
I am very new to 3D printing and Octoprint. Had been using Octoprint with my ender 3 pro for about a month.
I use Cura slicer and all the gcode starts with heating up the bed and nozzle before the print starts. The gcode works regardless whether I initiate it using micro sd card or through octoprint. However, just a few days ago, I changed my mother board to skr mini e3 v1.2 and lcd to TFT35. I also added a usb webcam.
Since then, whenever I start the gcode via octoprint, it would skip all the preparation steps and go straight into printing even when the bed and nozzle wasn't heated up. I was using a bad power supply initially and there was always an undervoltage warning. But a few days ago I also changed the power supply and there was no more undervoltage, yet the initial gcode was still skipped.

I thought the issue was that the pi wasn't behaving normally because of undervoltage but it's still the same after changing the power supply. It's either problem with Marlin 2.0 or maybe it was due to me connecting the usb camera? I tried printing directly using microsd from the mother board and it works normally. I haven't try removing the webcam yet.

Also the webcam stream is really slow and laggy.

Does anyone knows what is the issue?
is it:

  1. faulty Pi?
  2. somehow the webcam is slowing down the pi?
  3. compatibility issue with Marlin 2.0?
    or something else altogether?

Hope someone can shed some light on this. Thanks in advance!

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Sorry. I'm not sure where to obtain the log, is it from the terminal? if yes i will try to get it the next time I try printing again.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

I'm using Raspberry Pi 3B+, Octoprint Version 1.4.0, Ender 3 Pro, latest Marlin 2.0.x bugfix. I'm using a Mac and browser is Chrome.

Let's look into your start gcode. Post it here or upload a small gcode file.

Below is my starting Gcode

;Generated with Cura_SteamEngine 4.6.1
M140 S60
M190 S60
M104 S220
M109 S220
M82 ;absolute extrusion mode
; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes

I got the same start gcode.

Try it again in safe mode in case a plugin is causing this.

ok. thanks. Will try again in safe mode later and also try again by unplugging the camera and see if there is a difference though I don't think it's caused by the camera. Thanks again. Will update here once I've tested it.

Hi, I've tested in safe mode and it works fine.

I disabled Octolapse and it works fine. Could it be my octolapse settings that are giving me problems or octolapse itself?

Below is the octoprint log. I personally have no idea how to read it lol. Hopefully you or someone can help me to identify the issue. Sorry for the trouble and thanks in advance!

octoprint.log (135.3 KB)

maybe @FormerLurker can help you with that.
I never used octolapse.

You likely have test mode enabled within octolapse. Please take a look at the getting started guide which explains all of this.

1 Like

Ah yes. I have. Ok. I will read through the guide. Thanks! Any problem I will check with you again. Appreciate the help.