Octoprint behind proxy

I'm trying to setup octoprint behind a proxy to get https running well. I first setup octoprint and then put haproxy in front and it looked fine, but I couldn't login, bad password. The password was fine, it was saved by the browser and I triplechecked it. So I tried again, now with nginx in front, same result. So I tried to scrap the whole octoprint install and install from scratch. I enter https://my.server.tld/ and it greets me for the first login, fine, then I get to the authentication bit and it asks me for username and password. I enter them, but it doesn't want to save anything. I'm usually using firefox (recently upgraded) and I just tried Brave to check if there were any differences. Nothing. So - what sort of witchcraft is it Octoprint is doing here? This was installed with pip an hour ago, so it's fresh. Firefox 122.0.1 and Brave is version 1.62.162, based on Chromium 121.0.6167.164. I've tried rather a few times now and I'm starting to meet my limits - please help.

Thank you! This was brilliant. I just kept using nginx, since that was the last one I was dealing with and it integrates better with certbot than what haproxy does, so it just works. I owe a [some sort of drink you fancy]!

1 Like