Octoprint boots back to 1.8.7 and safe mode after update

My octoprints boots to safe mode 1.8.7 no matter what version I update to?

I have an Ender5 Pro and it has worked for years no problem. Some months back I think after an update to 1.8.7 Octoprint just boots in safe mode. I can update to the latest version and after a restart from instal everything works fine and the latest vesion is shown. However, when I power down and then startup octoprint it reverts back to 1.8.7 with all system update messages from before installation of the latest update. I have tried to update many times over the last few months with the new versions as they come out and the new version always loads then fails after a power down.
I also get the message " Warning: Firmware Broken

Your printer's firmware is known to have a broken implementation of the communication protocol. This may cause print failures or other annoyances. You'll need to take additional steps for OctoPrint to fully work with it." My 3D printer has always worked fine over the last few years with octoprint.

What did you already try to solve it?

I have updated to the latest versions of Octoprint as they came out over the last few months but the new software updates and runs OK and prints perfectly until I power down then power back up. I have also loaded "Creality-2x-temperature-reporting-fix"

Have you tried running in safe mode?

Booting in safe mode is the issue

Did running in safe mode solve the problem?

No octoprint boots into safe mode

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Version 1.8.7
octoprint-systeminfo-20230804054937.zip (39.3 KB)

Version 1.9.2 loads and prints from this this OK but reverts to 1.8.7 after hard power down and power up
octoprint-systeminfo-20230804060312.zip (54.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @Brett_Oliver !

The normal boot to 1.9.2 appears in this log, but not the print and the revert to 1.8.7

Found this in plugin_softwareupdate_updates.log:

2023-08-04 06:00:37 - OctoPrint - 1.8.7 -> 1.9.2 - SUCCESS - Update successful (Release notes: https://github.com/OctoPrint/OctoPrint/releases/tag/1.9.2)

Found this in the plugin_softwareupdate_console.log:

2023-08-04 06:00:31,335 > Attempting uninstall: OctoPrint
2023-08-04 06:00:31,335 > Found existing installation: OctoPrint 1.8.7
2023-08-04 06:00:32,339 > Uninstalling OctoPrint-1.8.7:
2023-08-04 06:00:32,340 > Successfully uninstalled OctoPrint-1.8.7

How do you tell it's still 1.8.7?

octoprint.log also shows starting 1.9.2

2023-08-04 06:00:45,105 - octoprint.startup - INFO - ******************************************************************************
2023-08-04 06:00:45,110 - octoprint.startup - INFO - Starting OctoPrint 1.9.2
2023-08-04 06:00:45,110 - octoprint.startup - INFO - ******************************************************************************
1 Like

Hi there are 2 system info budle zips enclosed(I had to expand it to see it). I have labled them 1.8.7 and 1.9.2. 1.9.2 installs fine and prints OK then after power off power on reverts to 1.8.7 again.

octoprint-systeminfo-20230804172718_187new.zip (39.8 KB)
This is the systeminfo bundle after powering down version 1.9.2 and powering up again. Tt's reverted to 1.8.7.

It appears you are not running on a Raspberry Pi and so not OctoPi.

How/with what guide/script did you install OctoPrint on your system?

Running on a Pi v3. Why do you think it's not a Pi? Maybe that's the issue?

I suspect ewald thinks that because the Pi Support plugin is missing maybe? The pathing in the logs seem to indicate the same path as octopi image /home/pi/oprint though. I think your fastest route at this point, based on the weird behavior, is to create backup, download backup, flash latest OctoPi image and then restore backup during initial setup wizard.


vs mine:

1 Like

You read my mind :sunglasses: :+1:

My suspicion could be a dying SD card as well. If you are saying it just reverts back to a previous state, then that is indicative of the SD card maybe going in to 'read only' mode?

The two original systeminfo bundles do match up to being from the same instance, with the timestamped logs showing pre and post upgrade. The new bundle that you've added in the follow up post shows no record of the upgrade, everything prior being the same.

Thanks for the replies. I have a faster SD card spare so now may be a good time to reinstall. Just noticed my OctoPi version is 0.18.0.

Thanks for your help everyone. I have now put a clean install on a new SD card and everything is working as it should again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.