Octoprint Camera continuously disconnecting

So, because I’m stuck at home I decided it was a perfect time to try to set up octoprint for my CR-10 Mini. Unfortunately, my 720p Logitech webcam (no model number is printed on it other than 720p and the Logitech logo)is having severe difficulties with the Pi 4 2Gb that is using. I can boot up to octoprint and see and control the printer from the online controls, but if I try to then go to the control tab and use the webcam it only refreshes once every 4-10 seconds, I have both the printer and the webcam hooked up to the usb 3.0 ports, and when I try to use octolapse it spits out an internal error every time I start a print. When the error doesn’t come up, the webcam will still disconnect after 1-2 snapshots. I have the classic time lapse turned off, but it isn’t just the octolapse that looses video feed. I also have AstroPrint set up and it also looses connection at the same time. My guess is it’s the camera and I should just buy a pi cam v2 or the Adafruit cam. I’ve also included the log for octolapse. (Octoprint’s is too big for me to upload). In the octolapse log I continuously saw this error AttributeError: 'NoneType' object has no attribute 'snapshot_command. Don’t know what this means, hope you guys can help. Thanks

plugin_octolapse.log (103.5 KB)

Edit: so I plugged the webcam into my computer and found out that it is a Logitech B525, with a maximum resolution of 1920x1080, 2.1 mp, and it runs pretty smoothly, so I wonder if it is just a compatibility issue.

Same issue here unfortunately, with a Pi 4B and Logitech C270. Seems to be since the latest Octoprint update.

You might try to put that serial connection for your printer on one of the USB v2 style of connectors as well as your webcam.

Ok, I tried that and it will work at first, with an average frame rate of about one frame every 1-2 seconds for the first 20-30 seconds, then it goes down to once every 10-20 seconds. I’ve also tried with one in the 3.0 and the other in the 2.0 port and got roughly the same results

Same problem here, the webcam frequently disconnected.