Octoprint cant connect to printer as firmware is corrupted

What is the problem?
I have a raspberry pi 4b, and a creality ender 3. I recently updated it to have a silent 4.2.7 motherboard and a BlTouch. i updated the firmware and now octoprint doesn't connect to the printer, I have reinstalled octoprint and tried 10 different cables to connect to the printer and none worked. after restarting octoprint and the printer multiple time, magically overnight it connected and it said

your printer's firmware is known to have a broken implementation of the communication protocol. this may cause print failures or other annoyances. you'll need to take additional steps for octoprint to fully work with it.

i assume this was the reason and tried firmwares from all the different websites and i still get the message.
Let me know how to do it

I've never used stock firmware so I'm not 100% sure which issue it could be - but if you got a temperature output like this

TT::27.7627.76  //0.000.00  BB::39.3539.35  //0.000.00  @@::00  BB@@::00

in the terminal, this plugin should fix the issue for you:

already tried that and didnt seem to help

i cant connect to my ender 3 to octoprint via my raspberry pi. it hasnt been connecting unless i uninstall any plugin .then the disconnect button becomes a connect button and it works. the serial port can recognize my USB but can't connect to it, same with the Baudrate.

i have treid everything i could think of , i have tried
multiple USB's (only data transfer ones)
re installing octoprint on the pi
re flashing the firmware
running in safe mode

and everything else that is in the community support

Please let me know as this is a big pain

Opening multiple threads and adding posts to very old threads on your one problem brings no faster solution.

Besides, this also can be a software issue, not electronics alone.

So we need more information about your setup and most important the systeminfo bundle

P.S.: Can a mod merge the threads (@PrintedWeezl maybe?)

1 Like

merged both threads :slight_smile:

1 Like

I am running that board with a Pi 4 on Jyers firmware, no problems at all.