OctoPrint can't connect via serial port to 3d printer

What is the problem?
Since today, OctoPrint can't connect to the printer (MonoPrice Select Mini V2) via USB cable.
Yesterday was working fine. I didn't print anything yesterday, but I tried to use the command M300 to play some tone.
What did you already try to solve it?
Changed USB cable, OctoPrint safe mode, restarted the Raspberry Pi multiple times and the printer, disabled every plugin installed.
The problem is that the Raspberry didn't recognize the serial port.
Then, following this post, I enabled again the serial port using raspi-config. Since then, OctoPrint recognize the serial port but can't still connect to the printer.
The serial port recognized by the system is the ttyS0.


Additional information about your setup
OctoPrint version: 1.4.0
OctoPi version: 0.17.0
Raspberry Pi Zero W
Printer: MonoPrice Select Mini V2
Printer firmware: 41
Malyan/Monoprice Connection Fix: installed version 0.1.3

Recently I didn't install any Debian updates.

Did you try to select the port and baudrate manually?

1 Like

Yep! Serial port /dev/ttyS0 and baud rate 115200 (I'm not 100% sure about this value). Still doesn't work

The printer is working fine, I can connect with Cura through USB cable. Now I'm going to reinstall OctoPi

That doesn't look right. Unplug your printer, replug it, refresh the port list. I'd expect it to show up as /dev/ttyUSB0 or /dev/ttyACM0. If all your system is seeing are ttyS ports your printer is probably not being properly detected on the OS level.

1 Like

Nothing. I tried to reinstall OctoPi from zero, withouth any plugins (just the Malyan/MonoPrice Fix) and any updates and still it doesn't work.
I think I should resign myself that my Pi Zero is somehow broken.
Anyway, thank you for your help

You really shouldn't be using a Pi Zero anyhow, I'm not recommending against it just for the fun of it...

1 Like

Yeah I know, but that was what I had. Now I've just ordered a Pi 4

That post indicated that they had connected their printer via GPIO pins. You'd indicated that you're connecting your printer via the serial cable. So this advice wouldn't apply to you.

The Zero isn't a recommended Pi computer for OctoPrint since it has only one core and half the memory. It's not that it's broken. It's just under-powered from a processing standpoint.

1 Like