Octoprint can't detect the printer

What is the problem?

My ender 3 S1 printer is easily seen by my PC but not by octoprit.I tried to reinstall everything octopi several times, I tried two different cables and with both I can connect to the PC. I didn't install the plugin but I tried safe mode anyway.I can't get the printer to be detected in any way.The only thing I noticed is that the PC communicates with the printer via the CH341 driver.
The story is this: I was already using octoprint. But to power the Raspberry from the printer, the Ender's motherboard burned out on the USB side. So I couldn't use raspberry anymore. In the meantime that the new motherboard arrived, I updated octopi and now nothing works anymore.

What did you already try to solve it?

Different cable
Different turn on combinations.
Followed the official guides of ticking off the various options.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Raspberry pi 3b+
Ender 3 s1

Tried this guide. Nothing changed.



I don't see ttyUSB0

Do you see anything it all with dmesg?


And this

I mean when you connect the printer
disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

Hm there is nothing at all so a simple driver won't fix it.

You can enable a continuous output with dmesg -w and test different cables and ports until you get something

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.