Octoprint can't find arducam V2.2 on Raspberry pi V4 B

What is the problem?

Octoprint 1.9.3 (new camera stack) on Raspberry 4B. Octoprint works but the Pi camera is not recognized. Can't seem to figure out how to get connection to camera. I am not code-literate but have gone into pi terminal to try some suggestions. Yeah, I know, that may be part of the problem, lol. Don't think I've done any damage though.

What did you already try to solve it?

Tried to insert this without success

  1. Disable legacy camera in Raspi-Config
  2. sudo nano /boot/config.txt
  3. Find the line: camera_auto_detect=1, add the following line underneath that one:
  4. Also enable dtoverlay=ov5647 under the [all] section (not sure if this is really needed, but doesn't hurt.)
    Also ensured camera cable is installed correctly as well as camera/lens are seated correctly.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

camerastack-journal.log (7.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
octoprint-systeminfo-20240108163741 (1).zip (151.2 KB)
Windows 11 , Octoprint 1.9.3, Raspberry Pi V4B, Arducam V2.2 8MP, Octopi 1.0.0

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.