OctoPrint can't set (bed) temperature of my Printer (Ender 5 Plus)

What is the problem?

OctoPrint is not able to set the (bed) temperature of my Printer (Ender 5 Plus + Silent Mainboard V2.2.1).
If I try to set the temperature via GUI, it has no effect. The printer shows that the target temperature is now 65°C, but it does not start to heat up.
If I disconnect the OctoPrint Pi and manually put the temperature into the printer, it will heat up without any problems.
The same is with prints. prints from octoprint will timeout with a bed-heat-up failure, prints started on the printer itself are working without problems.
Sometimes its working to get octoprint to heat up the bed, but it will then never stop. I've just got it to heat up, but after 5 minutes the bed had 95°C instead of the given 65°C.

What did you already try to solve it?

restart everything, updated octoprint to newest version.

Have you tried running in safe mode?

yes, no change in behaviour

Did running in safe mode solve the problem?

No

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Send: M140 S0
Recv: ok
Recv: == T:24.02 /0.00 == B:49.06 /0.00 @:0 B@:127
Recv: == T:23.95 /0.00 == B:49.42 /0.00 @:0 B@:127
Recv: == T:24.02 /0.00 == B:49.75 /0.00 @:0 B@:127
Recv: == T:24.06 /0.00 == B:50.13 /0.00 @:0 B@:127
Recv: == T:24.06 /0.00 == B:50.45 /0.00 @:0 B@:127
Recv: == T:24.06 /0.00 == B:50.75 /0.00 @:0 B@:127
Recv: == T:24.02 /0.00 == B:51.11 /0.00 @:0 B@:127
Recv: == T:24.22 /0.00 == B:51.35 /0.00 @:0 B@:127
Recv: == T:24.22 /0.00 == B:51.72 /0.00 @:0 B@:127
Recv: == T:24.02 /0.00 == B:51.99 /0.00 @:0 B@:127
..........
..........
Recv: == T:24.65 /0.00 == B:58.57 /0.00 @:0 B@:127
Recv: == T:24.61 /0.00 == B:58.85 /0.00 @:0 B@:127
Recv: == T:24.65 /0.00 == B:59.13 /0.00 @:0 B@:127
Recv: == T:24.73 /0.00 == B:59.39 /0.00 @:0 B@:127
Recv: == T:24.73 /0.00 == B:59.60 /0.00 @:0 B@:127
Recv: == T:24.80 /0.00 == B:59.92 /0.00 @:0 B@:127
Recv: == T:24.65 /0.00 == B:60.19 /0.00 @:0 B@:127

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.5.3
Python 2.7.16
OctoPI 0.17.0
Raspberry Pi 4 (4GB)
Ender 5 Plus + Silent Mainboard with original Firmware V2.2.1

Does anyone know what I can try to fix this? Is it a bug in OctoPrint or some wrong setting?
Thanks in advance!

Additional Log, where I set the temperature. Seems the printer gets the destination temperature but is not applying it.

Recv: == T:20.00 /0.00 == B:19.34 /0.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.34 /0.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.30 /0.00 @:0 B@:0
Recv: == T:20.04 /0.00 == B:19.30 /0.00 @:0 B@:0
Send: M140 S65
Recv: ok
Recv: == T:20.00 /0.00 == B:19.37 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.37 /65.00 @:0 B@:0
Recv: == T:20.16 /0.00 == B:19.18 /65.00 @:0 B@:0
Recv: == T:20.04 /0.00 == B:19.02 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.26 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.30 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.37 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.22 /65.00 @:0 B@:0
Recv: == T:20.16 /0.00 == B:19.34 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.30 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.30 /65.00 @:0 B@:0
Recv: == T:20.08 /0.00 == B:19.37 /65.00 @:0 B@:0
Recv: == T:20.00 /0.00 == B:19.37 /65.00 @:0 B@:0

Did you double check you turned your printer on? If not, it could be that the Raspberry Pi is powering the printer motherboard, which lets it communicate but not power the heaters or the motors.

1 Like

Thanks for your answer,
Yes, sure. Printer Power Supply is turned on :slight_smile:

For some magic reason, without changing any settings it started to work after I restarted pi + printer some more times. I cannot tell if it is fixed now, but for now its working and I've started a 10h print. lets see if it will work.
I will update this topic after the print finished.

Just curious: Do you have a SD card in the printer? If yes, try without.

1 Like

Hi Ewald_Ikemann,

I had the problem again right now and yes, I had an sd card installed. I plugged it out and it started working like as expected.
It seems that this did the trick... :smiley: Awesome! Thank you so much!
regards Marvin

1 Like

Those SD card shenanigans will be the end of me. I don't understand how one can break a firmware SO much that the presence or non-presence of an SD card influences heater operation. It's... disturbing, worrying and frankly just aggravating.

5 Likes

Had the same problem... printing from micro SD-card without any problem, with Octoprint connected no response after Bed-heating command M140 Sxx...

Found this topic, read the possible solution by removing the micro SD-card... That did the trick...

1 Like

Hi all - I have a challenging one for you: Same problem as you all had, except my SD card slot is broken, so presumably Octoprint thinks there is a card inside, but there is nothing I can do on that end.

Any ideas?

Many thanks!

James

Hello @James_Haywood !

It's not OctoPrint that complains about the SD card. It's the printer's firmware that gets out of order with a SD card in.

When the SD card slot is mounted on the printers mainboard, it can get very difficult to remove/repair it. Most easy: New board. Recommendation in this case: A 32bit board.

Hello everyone. I just purchased an Ender 5 Plus and ran into this issue. Fortunately, I found this page after a couple hours of trying to figure this out and removing the SD card fixed the issue. However, I do not like that I have to remove the SD card. Is there a way to update the firmware to keep this from being an issue? Or is there a pre-patched firmware available that fixes this? While I can, I am trying to avoid having to patch the firmware myself.

1 Like

You can download and install vanilla Marlin, you should build it yourself but you don't need to 'patch' it. There's usually an example configuration, for your printer that would be here:

There's loads of guides about configuration and building Marlin, it's a good thing to do since (as you are aware) Creality has its weird... issues.

1 Like

@Charlie_Powell thanks! I downloaded Marlin and the configuration for the Ender Plus. The one that I got to compile was 2.0.7. (I kept getting version errors with 2.0.* and compile errors with bugfix-2.0.*) I connected to the printer using Creality Slicer and updated the firmware. However, after doing this, the display became partially garbled and what I could read appeared to be maybe Chinese. As you probably know, the Ender 5 Plus has a separate firmware. Did that get messed up somehow through this process?

I have checked that the configuration file has #define LCD_LANGUAGE en.

While I am nowhere near new to programming or 3D printing, I am new to firmware compiling as the printer I have been using was a Flashforge Dreamer which uses a custom firmware for which source was not available (at least last I checked). Did I do something wrong in the process?

BTW, I was able to reflash the stock firmware from Creality, and it works as it did before, so the printer is still fine.

I'm not aware of how the Ender series screens firmware works, I was hoping someone else might be able to advise here.

You may also get more assistance from the Marlin community, such as on their Discord server.

This happened to me but only on one of my Ender 5 Pluses removing SD card did fix the issue though, but I am wondering why only one had this issue

Hello @Sequoyah_Robotics !

It's Creality :man_shrugging:

I did figure it out you can not have any file folders or .stl s on your sd card, it can only have .gcode files. It is a Octoprint problem most likely (@ma-mod @Ewald_Ikemann )

1 Like

Just tested it on my creality 4.2.2 board with my own firmware
2 folders / some stl files / some gcode files

no issues at all

Recv: Begin file list
Recv: CE3PRO~1.GCO 90157062
Recv: CE3PRO~2.GCO 19541262
Recv: /FOLDER1/CE3_MA~1.GCO 18408614
Recv: End file list

Marlin reported the files as expected and I was able to set the temperature on the screen and aswell in Octoprint.

Sorry I didn't know but it was the default stuff Creality puts on the sd card that was in folder so it had .pdf, .png, .jpg, .pkg, .msi, .sys, etc
@PrintedWeezl

The SD card trick worked for me! Thanks!

As another data point, though, I connected the printer to Cura directly (via USB) before, and that worked with the SD card in and without the bed heating problem. It might be interesting to take a look at what Cura does differently...