Octoprint Can't Update Printer Profile After Fresh Install

What is the problem?
On a freshly flashed Octopi 0.17.0 (I have tried 2 SD Cards, 2 different Pis (2B and 4B) and 2 different Wifi networks)

During the setup wizard I named my printer CR10 and put in it's print bed dimensions but it doesn't take. When I go to settings-->printer profile it shows the printer as default and generic rep-rap printer with the default 200 x 200 x 200 build area.

I find that I cannot update my printer profile. I can add a new printer profile but it will not register other than the default 200 x 200 x 200 build area. I also cannot set it to default. Eventually an error pop-up will appear "Could not update printer profile".

What did you already try to solve it?
Tried different Pi, different SD card and wifi network.
Googled for similar issue reports. I haven't found one that's quite the same.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
octoprint logs.zip (8.9 KB)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
I'm using the latest version of OctoPrint straight from the website, no extra plugins. I've tried a new SD Card and have use a Pi 2B and 4B and get exactly the same result. I get this error straight after install. If anyone can figure out what's going on I'd sure appreciate it.

Just as an update I flashed octopi-stretch-lite-0.16.0.zip to another sd card and I can report that I am able to setup my printer profile as expected. So it seems like there is a fault in the 0.17.0 image. I'm going to keep using 0.16.0 and disable updates for now.