Octoprint - Change Filament plugin - Big problem

What is the problem?

Today I was making a printout. 5h and 30min.

With only 1h and something left, it started to have a small problem of retractions.

I paused the print, to interact with "Change Filament" plugin.

I took out the filament, put it back in, extruded and when everything was ok, I pressed the "Resume the print job" button.

When I hit it, the extruder moved to the point where I stopped printing.
And there, it has started to pour filament, a lot of filament at the same point, making noises the filament stepper motor, and without moving or anything.

I show you a video

And logically, I lost the print completely, I could not finish the piece.

Do you know why this happened, did I do something wrong, how can I avoid this problem in the future?

What did you already try to solve it?

I have not done anything concrete, since it just happened to me and I have not been able to finish my printout.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!

octoprint-systeminfo-20240102151811.zip (362.0 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version: 1.9.3
Change Filament Plugin: 0.3.2
Printer: Creality Ender 6
Firmware: Marlin2.0.1-HW-V4.3.1-SW-V1.0.4.9-BLTouch
Browser: Google Chrome (I have tried in Firefox, and in Safari)
Operation System: MacOS Monterey (12.6.8 (21G725))

This sounds to me like a mismatch between relative and absolute E (M82, M83, or G90, G91). See https://marlinfw.org/meta/gcode/ for details on each of these commands.

Different slicers have different defaults for E values. Some use absolute from beginning to end, some use absolute with a reset at the beginning of each layer, and some use relative.

Unfortunately, there's no gcode command to detect what the current setting is so any plugins have to match the slicer defaults (or the current slicer setting).

To determine if this is the problem, we need to know what slicer you are using and probably need some sample gcode output from the slicer. I suggest that you slice something small, like a 5mm cube and try the change filament at 2.5mm layer height.

El slicer que estoy usando, es Ultimaker Cura

Ok. I'm trying to make this piece
But what do I have to achieve? what is the goal?
I print a 5mm x 5mm x 5mm cube and set the line height to 2.5 and what should happen?

From your description of the problem, you paused the print and did something with the change filament plugin but upon resuming, there was a massive amount of filament extruded. I believe this is caused by a mismatch between relative and absolute E.

To confirm my theory, I'd like to see you reproduce the problem with a small object, not one that takes 5+ hours to print. Then I'd like to see the gcode from that small object.

If my theory is correct, the plugin changes E to relative but doesn't set it back to absolute and when the gcode resumes, the next command that has a large E value will extrude that large amount of filament.