Octoprint connection down, printing continues well

I'm using the latest octoprint with updated linux but a week ago my octoprint web and SCP connection goes offline repeatedly but printing goes well.

Looked for errors in the octoprint.log and found these:

(standard input):2024-05-24 17:34:58,106 - octoprint.plugins.octoeverywhere - INFO - Blocking lowest latency endpoint, since we failed while the WS connect was happening.

(standard input):2024-05-24 17:34:58,107 - octoprint.plugins.octoeverywhere - ERROR - OctoEverywhere Ws error: [Errno -3] Temporary failure in name resolution

(standard input):2024-05-24 17:34:58,108 - websocket - ERROR - [Errno -3] Temporary failure in name resolution - goodbye

(standard input):2024-05-24 17:34:58,108 - octoprint.plugins.octoeverywhere - INFO - Service websocket closed.

(standard input):2024-05-24 17:34:58,109 - octoprint.plugins.octoeverywhere - INFO - Disconnected from OctoEverywhere, server con wss://starport-v1.octoeverywhere.com/octoclientws[8]

(standard input):2024-05-24 17:34:58,109 - octoprint.plugins.octoeverywhere - INFO - Closing all open web stream sockets (0)

(standard input):2024-05-24 17:34:58,110 - octoprint.plugins.octoeverywhere - INFO - Sleeping for 91 seconds before trying again.

(standard input):2024-05-24 17:36:29,175 - octoprint.plugins.octoeverywhere - INFO - RepeatTimer thread exit

(standard input):2024-05-24 17:36:29,177 - octoprint.plugins.octoeverywhere - INFO - Attempting to use lowest latency server: wss://lon.octoeverywhere.com/octoclientws

(standard input):2024-05-24 17:36:29,178 - octoprint.plugins.octoeverywhere - INFO - Attempting to talk to OctoEverywhere, server con wss://lon.octoeverywhere.com/octoclientws[1] wsId:2929820208

I think the problem around the websocket version. Anybody have idea hot to fix it?

What did you already try to solve it?

Tried to reinstall octoprinteverywhere plugin.

Have you tried running in safe mode?

Yes it works without plugins in safe mode

Did running in safe mode solve the problem?

Yes it works without plugins in safe mode

Systeminfo Bundle

Raspberry Pi4 2Gb with OctoPrint imager


Additional information about your setup

OctoPrint version : 1.10.1
OctoPi version : 0.18.0
Ender3 S1 Pro
Windows, iOS, octoeverywhere, both fail
Chrme, app, etc

Hello @itrockstar !

Please do not post log excerpts in an improper way. (Wondering where the slants and bold letters do come from?)

Further down it is asked for the systeminfo bundle. Please attach it to your next post.

1 Like

Here you can find system logs
octoprint-systeminfo-20240524190015.zip (98.4 KB)