Octoprint continuous network issues on public network

What is the problem?
Basically, I live at an apartment complex that has an open wifi network that you typically have to sign into on a web browser in order to use. I could not connect or find my pi on the network originally but I ended up getting that working. Now, I can connect to the pi on my PC but it has no access to the internet. The annoying thing is that yesterday I was able to ping both the DNS server and even webpages like www.google.com with little issue. But somehow something changed and now I can't ping either. I had a fix I was gonna try to do a fix I found for the state the printer was in yesterday but I never even got the chance. I have it set up to a static IP address and I have and set up for DNS servers but nothing is working. It would be one thing if I had done something to cause it to stop working but the fact that I didnt and it stopped is extra annoying. Any help would be appreciated. I've been working on this for weeks.

What did you already try to solve it?

I already mentioned some things above but I have changed the DNS servers changed ethernet ports and cables and have gone through many online forums looking for the answer but none have worked so far.

Logs (syslog, dmesg, ... no logs, no support)

octoprint.log (1.5 MB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Open wifi network with browser sign in typically but also has the option to connect a device to my account with a MAC address which I have done. Static IP address. Connected to ethernet through ethernet switch (I have tried connecting it to its own port with no success) and we had to manually set mostly everything up. I can answer any questions or provide any command outputs if needed.


First of all I don't think it's a good idea to put your printer on a public wifi.
You never know how it's configured and who lives in the next apartment.

If you still want to do it:
I guess you have to log in the captive portal first to get internet access on your pi.
One way to do that is to install the desktop environment and to use the browser to log in. You may also want to activate the vnc support so you can remotely connect to the pi from your pc.

You have to download a few packeges for the desktop environment (and maybe for the vnc server) tho.
I would suggest you create a hotspot on your phone and connect the pi to it and install everything needed.

Yea while a public WiFi network is definitely not ideal I don't have many other options because I want octoprint so that I can remotely monitor my printer for failed prints and even fire. And as for the desktop idea, I forgot to mention I have tried that but every time I went to login I would get stuck in a login loop and could never get in. If I could I think it would solve all my problems. I tried for a week or two on that idea but it never went anywhere. I talked to multiple Linux people and browsed lots of forums but couldn't even get close to an answer for that one. This time I was so close but then something changed.

Also before anyone asks here is the output of some common commands

pi@octopi:~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    202    0        0 eth0   U     202    0        0 eth0

pi@octopi:~ $ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::a3d4:a735:d6ae:f9e6  prefixlen 64  scopeid 0x20<link>
        inet6 fde3:b583:bc6a:3:9e47:dff6:bb4e:b7e8  prefixlen 64  scopeid 0x0<global>
        ether e4:5f:01:02:4d:b7  txqueuelen 1000  (Ethernet)
        RX packets 16029  bytes 1970507 (1.8 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 814  bytes 103159 (100.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 17  bytes 2150 (2.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 17  bytes 2150 (2.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether e4:5f:01:02:4d:b8  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Here is what is in the /etc/resolv.conf file

# Generated by resolvconf