Octoprint crashes when I pause a print, (CR-10S Pro)


Brand new to Octoprint so please accept my excuses in advance. I have a Creality CR-10S Pro which I have been using for big, fast prints for 6 months now. I need Octoprint because I'm tired of the SD card shuffle but also because I want some security when I'm away from the printer. Here's my issue:

Install and setup of Octopi on a brand new 'official' pi 3b (with mains adaptor), went fine. Connecting to my printer ditto. I had some problems with temperature parsing but thanks to this forum, found the solution and added the plugin. All is good except that if I pause a print, Octoprint crashes to the point that I cannot reboot it other than by physically unplugging the pi.

My printer firmware is up to date, (1.60.7 stock), and I am running Octoprint 1.3.11 on Octopi 0.16.0

Any help would be very welcome !

Hello @NickD,

for you need the temperature correction plugin, deactivate all other plugins you may have installed and see if you can pause without issue.

Also, what are the G-Codes you have entred for pausing?

Thanks for the swift reply.

Apart from the plugins included with Octopi, I added Octoprint Anywhere and Firmware Updater.

I'm pausing the printer from the console, not by sending GCode directly.


So you have no G-Code scripts for pausing?

(I've none because I don't use it).
And try with disabled OctoPrint Anywhere.

No GCode scripts... (I'm a Newbie!). If I did have a pause script, I presume I could park the nozzle in a safe place, cool down the head and bed, turn off the fans etc. Then run a resume script to fire it all up again and pick up the print where it left off?

FYI, I did run with OctoPrint Anywhere off but with the same result. Except that I was too fast to blame "Pause". The culprit is "Cancel", which is when the crash happens.

OK, I get it. There's a place to add your custom pause / resume scripts which are run when I hit the console buttons. I guess there are some standard ones which I didn't get?

Another issue is that my console does not offer 'Resume' if cancel is enabled. I will fool around with some scripts and see if that changes anything. If anyone has some standard, basic scripts I'd be grateful.


If you search this forum for pause scripts you will get a bunch of possibilities.
Also have a look here: http://docs.octoprint.org/en/master/features/gcode_scripts.html for a bit more background information

By the way: you may shut off the hotend heating, but never do it with the heatbed, because the adhesion will fail and the model gets lose and it will be impossible to continue a proper print.

the adhesion will fail and the model gets lose and it will be impossible to continue a proper print.

I have the reverse of that problem, prints are sometimes too stuck down the bed !

Thanks for the info about the scripts. I'll mark this thread as 'solved'.

1 Like

If your print bed is removable like mine, throw it into the freezer for five minutes. Unless it's flexible-PLA it will definitely pop right off.