Octoprint Crashing after print completes

So I have a update on this and it's been a journey to get there I'll just leave it at that.

Past all the steps I took above I installed the creality board on the Aquila on Sunday and shockingly the errors continued and got worse when I hit cancel on octoprint during print octoprint crashed, when I hit cancel on printer it crashed. I flashed Jyers on the Aquila (Ender 3 v2 version) and for the record it runs but you do need to make some tweaks (won't go into details) to make it work.

Once I found out that the issues continued I started to backtrack from the printer to the pi and looking back I should have done this prior do to the fact that the printer prints perfectly just the octoprint issue mentioned. I replaced my USB cable cover the 5v put with electrical tape and problem went away. It's funny I used a brand new cable same exact type I used on my Ender 3v2 that runs flawlessly but this one was faulty. I put the old motherboard back it did ran protune on the heater from the Jyers menu and as of now ran 6 prints with no issues. Running Alex firmware and I actually went through the source code and it's indentical to Jyers Ender 3V2 version when it comes to the configuration.h files. Like down to ever single code.

So on print 10 or 11 no issues then yesterday I installed a dual extruder (simple setup) just adjuster the e steps for Extruder printed 1 print no issues then this morning printed and then octoprint crashed. I'm not going down rabbit hole just yet but I'll keep eye on. Next step will be check power to PI prehaps. I have the Creality board as a backup so in the rare chance it's the board I'll swap out. After Alex/Jyers firmware edit (minor changes) I did get some thermal runaway errors at start of prints . I did PID autotune and that seemed to correct it but I did have 2 pop ups always durring probing.

Is there anything new in the log file when it crashes?

Nope just as last time

Last command before crash is
octoprint.plugins.octoeverywhere - INFO - RepeatTimer thread exit

Here is a section of it

2021-11-19 08:18:28,414 - octoprint.plugins.action_command_notification - INFO - Got a notification: Les Aquila V1 Ready.
2021-11-19 08:18:28,420 - octoprint.util.comm - INFO - Finished in 6333.881 s.
2021-11-19 08:18:28,423 - octoprint.util.comm - INFO - Changing monitoring state from "Printing" to "Finishing"
2021-11-19 08:18:28,440 - octoprint.printer.standard.job - INFO - Print job done - origin: local, path: CE3PRO_2_Inch_Hollow_Ball.gcode, owner: pi2
2021-11-19 08:18:28,549 - octoprint.util.comm - INFO - Changing monitoring state from "Finishing" to "Operational"
2021-11-19 08:18:28,567 - octoprint.plugins.excluderegion - INFO - Printing stopped: event=PrintDone
2021-11-19 08:18:28,570 - octoprint.plugins.filamentsensorsimplified - INFO - PrintDone: Disabling filament sensor.
2021-11-19 08:18:28,588 - octoprint.plugins.octoeverywhere - INFO - RepeatTimer thread exit
2021-11-19 12:20:46,527 - octoprint.startup - INFO - ******************************************************************************
2021-11-19 12:20:46,530 - octoprint.startup - INFO - Starting OctoPrint 1.7.2
2021-11-19 12:20:46,531 - octoprint.startup - INFO - ******************************************************************************
2021-11-19 12:20:47,218 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity changed from offline to online
2021-11-19 12:20:47,416 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: online
2021-11-19 12:20:47,417 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to 1.1.1.1:53 is working
2021-11-19 12:20:47,417 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving octoprint.org is working
2021-11-19 12:20:47,485 - octoprint.plugin.core - INFO - Loading plugins from /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins, /home/pi/.octoprint/plugins and installed plugin packages...
2021-11-19 12:20:49,613 - octoprint.plugins.errortracking - INFO - Initialized error tracking
2021-11-19 12:20:49,751 - octoprint.plugin.core - INFO - Found 24 plugin(s) providing 24 mixin implementations, 57 hook handlers
2021-11-19 12:20:50,049 - octoprint.server.heartbeat - INFO - Starting server heartbeat, 900.0s interval
2021-11-19 12:20:50,060 - octoprint.server - INFO - Intermediary server started

I'm considering just putting the Creality 4.2.7 board in because my ender has none of these issues the Voxelab prints great and the board is a direct fit. I'll see definitely strange I'm running nearly identical firmware on both machines and this one is having all the issues.

I have to say its unfortunate that no one can help me with this. I first thought this was a cable error but its not, I tried multiple firmwares and issue continues. The printer prints perfect, octoprint works without issues and logs don't tell me anything. The octoprint program is the only thing that crashes after print completes. I forcused on the printer being the issue but there is something that is causing Octoprint to crash like this.

Usually when no one helps it's because we too don't know the answer - some things are not covered by a simple fix unfortunately.

This is a fairly wild stab in the dark, but since you had a filament sensor plugin installed, you could be getting segmentation faults. There's a bit of a problem with these GPIO plugins that causes segfaults. These aren't logged, since the process literally just stops dead in its track, which this seems like it does.

It's a long shot, but make sure you have no GPIO plugins enabled.

As well, if OctoPrint crashes, try and capture the output of sudo service octoprint status and that will show us if it was a segfault or not.

That sounds like a great idea I'll try that I do appreciate it I did plan on disabling all of my plugins that use a gpio just to eliminate that possibility because at this point I'm down to anything plugged into the the raspberry pi . Thanx

I removed everything that was plugged into my GPIO ports I had a relay connected for PSU control had a TP-Link smart plug laying around used that instead and also disconnected my filament sensor for now will most likely connect back up to printer directly if this works. Currently I have about 6 prints and no crashes. I would call this a success and mark solved but I have gone nearly 10 prints before it just started to crash so I'm not celebrating just yet. One thing that makes me feel good is that prior to removing all the GPIO stuff I couldn't have gone more then 2 prints without a crash so we are getting somewhere. Will update in the next few days once I get to about 15 prints without crash.

Sounds promising :crossed_fingers:

1 Like