Octoprint Crashing after print completes

What is the problem?

Octoprint crashing after print completes unable to access through IP after crash need to access through ssh and restart the octoprint service to regain access. When it crashes and i try to access the ip i get that screen "The OctoPrint server is currently not running" with some code to run like "Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:"

What did you already try to solve it?

I tried a different Raspberry PI 3 Model B, reinstalled entire octoprint from scratch and it worked for 2 days then started to crash again. prior to fresh install it was shutting down immediately after print the bed didn't even get a chance to move to front. This i feel was a issue with PSU control in some way but that was corrected after new install. I have log files ready if needed. Thank you

Have you tried running in safe mode?

I have not but with it running completely fine after new install i am nearly 100% positive in safe mode this will not be a issue. I suspect a plugin error possibly Spaghetti detective as that is the last code that pops up in logs before crash.

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20211112124917.zip (246.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

Hello @Lesfb !

As you are running OctoPrint 1.7.2, you should have seen this:

I did and I got the file do I attach the zip file? or do I pull a file out of it?

Please attach the file as is is (in a new post).

thank you updated original post.

Honestly?..

Ok will create a new post sorry

Ok, first this:

2021-11-11 22:21:01,285 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Serial status mismatch
| Last lines in terminal:
| Changing monitoring state from "Offline" to "Detecting serial connection"
| Performing autodetection with 1 port/baudrate candidates: /dev/ttyUSB0@115200
| Trying port /dev/ttyUSB0, baudrate 115200
| Connecting to port /dev/ttyUSB0, baudrate 115200
| Handshake attempt #1 with timeout 2.0s
| Connected to: Serial<id=0x754d50b0, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
| Send: N0 M110 N0*125
| Recv: Serial status mismatch
| Recv: Error:Serial status mismatch

Something is going on with that firmware.

OctoEverywhere has some trouble:

2021-11-11 22:16:09,879 - octoprint.plugins.octoeverywhere - ERROR - Failed to find time estimate from OctoPrint. int() argument must be a string, a bytes-like object or a number, not 'NoneType'

Then, as you expected, some errors with thespaghettidetective

And also this:

2021-11-12 00:36:59,627 - octoprint.plugin - ERROR - Error while calling plugin filamentsensorsimplified
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/__init__.py", line 271, in call_plugin
    result = getattr(plugin, method)(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/__init__.py", line 1737, in wrapper
    return f(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_filamentsensorsimplified/__init__.py", line 435, in on_event
    self.no_filament()
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_filamentsensorsimplified/__init__.py", line 323, in no_filament
    filaStatus = (GPIO.input(self.pin) + self.power + self.triggered) % 2 is not 0
RuntimeError: Please set pin numbering mode using GPIO.setmode(GPIO.BOARD) or GPIO.setmode(GPIO.BCM)

Any route I should take ? The firmware I am running is specific for my setup meaning bl touch and what not. I can try to reinstall it?

I was considering installing a stock version os resbian then install octoprint from ssh instead of doing install from octoprint image but I doubt that will solve anything.

Installing OctoPi with OctoPrint is the more easy way.

What printer do you use? Maybe the is another source for a Marlin version for that printer.

Understood. I'm using a Voxelab Aquila. I have a ender 3 v2 with identical setup no issues but with this printer clearly issues. I will flash new firmware and worst case get a ender 3 v2 board for it as that is a option. But I wanted to solve this without buying part for this semi new printer. And I would go the warranty route but the printer prints great just the connection issue with octoprint

You also may try this:

I actually have no 5 volt power coming from the pie to the printer so that's not an issue I actually have the 5 volt connection blocked off there.

1 Like

I'm going to search for a different version of marlin for this printer if needed what I'll do is I'll run the stock version with the BL touch version I'm nearly positive vox lab has that and I'll see if the problems continue I don't really care too much about the display and how nice it looks because I do all my controlling from octo print only reason I got the custom firmware initially was I didn't have a BL touch so I was using the mesh leveling and without custom firmware that was not possible so I'm going to do this route first and see what happens thank you for the help I will update once I get some things in motion

Unable to install stock firmware that works with 3d touch the stock firmware looks like it works until I try to run bed leveling then it checks one point and then retracts pin and stays in place.

Installed a beta version 3x3 bl touch Marlin Alexqzd version

[v1.3.5.1 Beta 4]
(Release v1.3.5.1 Beta 4 - Gcode Previews · alexqzd/Marlin · GitHub)

Will update on the few days and see if that did the trick also past this firmware I don't see other custom firmware that works with Voxelab Aquila with G32 chipset

Went back to the stable version of this firmware as this data version had the same issues and installed all plugins that were suggested in the GitHub page to resolve connection issue and display issues. It worked flawlessly for 2 prints then it went back to crashing again at the very end of the third print when it completed. At this point I am out of ideas. I looked online for a different version of marlin for this vox lab Aquila printer but was unsuccessful. I ended up ordering a different motherboard for a pretty good price I have a feeling that's going to be my only solution at this point as it's not an intermittent problem but it does run successfully after some changes are made in the settings but then it goes back to crashing and the logs aren't giving any clear indication to what the issue is. I'm leaning that it is a firmware issue but I don't understand how firmware would allow the octoprint to operate correctly and then two three prints later crash octoprint not the raspberry pi just the October Python program.

Have you seen this?

I came across this but there was no clarification if this is for the g32 chip with a new motherboard on order and it should be here tomorrow I'll test this out I was debating doing this because I don't want to mess anything up with the boards if I flash the wrong firmware but with the motherboard on my way might as well try this last firmware try and see if that does the trick I can probably get four or five prints in between today and tomorrow to test this out before installing that board if issue persists thank you so much.

Just in case anybody sees this thread that link above for the custom firmware is not for the g32 chip I just tried installing it and it did not install it gave me an error it actually deleted the bin file from the firmware folder after the error tried multiple times same issue the creality screen does work but all you see is the creality sign. Ended up going back to the Alexqzd firmware mentioned above but went with the stable 1.3.4 version as a last attempt to see if this will work I even created a new profile in octoprint before connecting to this printer again not that that would make a difference but I figured what the hell right now I'm doing my first test print will update as soon as I get two or three prints under my belt as it will not go past 3 prints without crashing octoprint at the end of printing.

New Creality 4.2.7 board on order as I'm going to be installing that in this Voxelab Aquila to fix this problem hopefully for good will update later.

2 Likes

Hey - I stumbled across this thread cause I'm having similar issues with my Aquila (G32 chip) also. Actually came across this by googling some of the error lines in my log...

Nevertheless, I did see this issue on the Jyer's Github for the Ender 3v2. From my understanding, the Jyer's Marlin firmware for the Ender 3v2 is really the same as the Alex firmware for the Aquila, with a couple configs changed (ie: the G32 has less memory than the STM32, but is otherwise a direct pinmatch to each other).

Long story short - we might have a firmware issue, instead of an Octoprint issue. But considering the popularity of the Ender 3v2 - i'm surprised there isn't more buzz on forums about this problem we're having.