Octoprint crashing during print - multiple printers

What is the problem?

During Printing, Printing stops and I have the following on the web browser for octoprint.

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

What did you already try to solve it?

-Updated Octoprint and Octopi to latest version
-Ran sudo apt update and sudo apt upgrade
-Formatted and started over with latest version available from Octopi

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

-There is only one plugin I install separately which is Astroprint. One of the logs does reference an error with the plugin, however normally it does not as the other two show. I don't know enough to know if that is causing it to crash or if its just logging this because whatever has crashed is creating the error.

-Happening on previous versions of Octoprint/Octopi as well

Attached logs
Printer98.zip (1.8 MB)
Printer59.zip (421.8 KB)
Printer82.zip (1.9 MB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.