Octoprint creates an image that takes up all storage?

What is the problem?

When octoprint does a timelapse, it fails to capture any frames, and it might be because its making a 27 Gigabyte image that then takes up all system storage.

What did you already try to solve it?

Tried to delete it and reboot, I got the storage space back but then when I did another print I was greeted with yet another 27 GB image.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, it made a 7 gb file this time, probably because I did a short print.

Systeminfo Bundle

octoprint-systeminfo-20230312174419.zip (86.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 V2, Jyres firmware, Octoprint 1.8.7, Python 3.9.2, OctoPi 1.0.0

I think your snapshot URL is configured incorrectly in OctoPrint's settings. It should be not


Alright, ill try that in a bit when my print finishes.

Seems to have worked, thanks!

Cool, what was happening was OctoPrint was requesting the stream URL (indefinitely loading jpg image) and it would never complete because the stream never does and just keeps getting bigger and bigger.

Ohhhhh, yeah i understand now, I wish octoprint told you that you had it on stream instead of snapshot.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.