Octoprint custom bounding box not working

What is the problem?

I have Prusa i3 MK3S, configured printer profile in octoprint 250x210x210 and select custom bounding box set for Y cord: -4 to 210. Because PrusaSlicer add Y -3 to clean nozzle. WhenI start printing using octoprint, line for cleaning nozzle print on Y: 0 cord.

What did you already try to solve it?

No :frowning:

Complete Logs

I thing no need for logs because all logs are ok. Only question is how to activate negative move in Y. I made gcode in prusa slicer app. If logs are necessary I will add it.


Additional information about your setup

OctoPrint 1.4.2, Prusa MK3S, FW 3.9.0, Windows 10, Chrome


Unfortunately not in this case.... Custom bounding box doesn't limit anything, it just helps in the UI to (a) not show the out of print area warning and (b) show on the gcode viewer.

Could you:

  • Enable serial.log, then start a print that should go to negative, wait until it fails then upload serial.log here
  • Upload the sliced gcode from the slicer, so I can compare with serial log to see if this is an OctoPrint issue.

Generally, logs are always needed when someone says 'OctoPrint xxxx not working' so we know what's not working :slight_smile:

Sorry I'm new in octoprint but I am delighted, here is log from serial:

serial.log (27.2 KB)

G-code: Prusa3D betman: Batman_0.3mm_PETG_MK3S_19m.gcode (177.6 KB)


I just looked into your gcode and there is no negative y (besides of the cleaning line at -3).
I guess something went wrong in your slicer. Maybe there is an auto center option or something similar.

Here is screenshot

Why print don't go Y -3 ?

Oh my bad I thought you wanted your print in the negative area.. I missed that part.

Let's test something else - home all axis and try to move y into a negative coordinate. Maybe the software endstop is active.

The serial log doesn't show an error in this part.

2020-09-06 09:42:09,040 - Send: N21 G1 Y-3.0 F1000.0*27
2020-09-06 09:42:09,070 - Recv: ok
2020-09-06 09:42:09,074 - Send: N22 G92 E0.0*105
2020-09-06 09:42:09,078 - Recv: ok
2020-09-06 09:42:09,082 - Send: N23 G1 X60.0 E9.0 F1000.0*66

I tested it moving in control tab for 1mm it didn't move in negative when come to y 0.

I don't know if the prusa firmware allows you to disable the software endstops.
That's the command https://marlinfw.org/docs/gcode/M211.html
Disable them with M211 S0

:warning:Be carefull - without software endstops nothing is stopping the printer from crashing into the walls.

Maybe this software endstops are activ when using usb printing(octoprint) when I print without octoprint only from sd card it's go Y:-3

maybe I'd better sacrifice this -3 negative then to crash into the walls

I have these settings for my Prusa and they work fine:

Hey, I find out when I assembling my enclosure after instaling RPI3 on printer I forgot to move my plexiglass a little further and heat bed on end stop because of plexiglass. SORRY its entirely my fault. I move plexiglass and its normal printing on Y:-3.

Sorry again for my topic, and thank you for helping me.

1 Like