Octoprint destroys sd card after update

when starting with OctoPi 1.3.12 with plugins installed ( Bed Visualizer Settings, betterheatertimout, displaylayerprogres plugin, Eeprom marlin editor, exclude region, floating navbar, Gcode editor, Navbar temperature plugin,octolaps, preheat button, printtime genius, simple emergency stop, tab order, terminal commands, themify and oponconnect)
after updating to OctoPi 1.4.0 it worked well untill after i rebooted the instance. from that moment on i could not get any response over the network (the UTP-leds didn't light up either).
after settingup another RPI with the OctoPi 1.3.12 version it ran perfectly.
when checking the first RPI and trying to install the OctoPi 1.3.12 version again it said the card was corrupted, so i took a new SD card and installed OctoPi 1.3.12. which was working perfectly again until i upgraded again -> card damaged again...
i have tried this multiple times over different RPI's and each time with a new SD card the result ends up being the same: damaged SD-card

the logs unfortunately aren't obtainable due to the damaged card

The RPI is a 3b+, the printer i use is a CR-10S with a TH3D marlin version and a Wanhao Di3 with the same RPI setup. they both have the same problem

Please Who Knows the answer to this problem

Try to update without any usb device connected. It might be a power related issue.

So if you put the card in a PC it reports as corrupt or can you read the boot volume? Are you able to reformat them and reinstall? Are the SD cards a decent make bought from a reputable store? There are a lot of fake/cheap cards on ebay etc. that don't work very well if at all. Same issue with USB sticks and Gotek drives, cheap ones don't work.

Also do you have another raspberry pi you can try, I have certainly had issues before where the sdcard holder has a pin with a dry joint. Causes all sorts of weird issues. (Couldn't complain it was me that soldered it). It could be a hardware issue with the Pi. I think it is unlikely that Octoprint is destroying cards.

the cards are decent, kingston and samsung evo, i have not been able to read them on a pc and when reformating i get the message that the card is dammaged and can not be loaded.
i Bought the cards at a store which sells quality stuff.
and yes i've tried it with different RPI's and they all have the same problem after updating.

when i do that i can boot just once and after a reboot the card is damaged

which power supply do you use for the pi

There are various guides and notes on recovery SDCards on PIs have you tried any? E,g.

You might be able to get at the logs that way.

But as mentioned, the power supply could well be the issue. As one of the few variables between all the people who have done the upgrade.

So, to omit confusion: What is the difference between OctoPrint and OctoPi? Are they the same thing?
So you want to update OctoPrint from 1.3.12 to 1.4.0.
What OctoPi version are you using?

I had the same issue and a broken card.