Octoprint Disconnected form WiFi during update

What is the problem?
I was busy updating my Octopi to the new version after reinstalling a new instance due to quality issues. After trying to reconnect, it is showing Octoprint in this format and won't log in

What did you already try to solve it?
I;ve tried reinstalling octoprint on the SD card but it's still doing the same thing. I've also tried rebooting.

Additional information about your setup
Was using Octoprint 0.16.0 and updating to the most recent version. This is on a Raspberry Pi Model B+ v1.3 (2015) and I'm trying to connect it to an Ender 3 Pro.

If anyone could help with this, I'd be highly grateful.

It appears to be missing the stylesheet (in theory). Try doing a hard-reload/refresh in your browser first to make sure. That's usually all it takes at this point.

If that doesn't work, it sounds like perhaps your OctoPrint didn't complete its upgrade...?

  • Obviously, OctoPrint as a service is running as is the haproxy instance
  • I'm guessing that it's a caching issue but not necessarily. Try the refresh.
  • If that's not it, then I would recommend another attempt at putting the OctoPi image onto your microSD card following the instructions.
  • If you keep getting wifi problems, try connecting the Raspberry via Ethernet cable during any upgrades which might want to talk to the network.
  • Also, if you're running something like PiHole on your network, you might turn that off temporarily or educate it so that it doesn't block the attempts that pip makes at updating things, for example

Hi, thanks for your response. I managed to get it working again with another fresh install and it's working fine now.