Octoprint disconnects intermittently from Ender 3 v2

What is the problem?

Octoprint on Raspberry Pi 3 intermittently disconnects from Ender 3 v2

What did you already try to solve it?

My issue is that my RPi3 will intermittently disconnect from my Ender 3 v2. It can happen at shorter and longer intervals of time. It happens when I print and when I'm at idle. I have reloaded Octoprint & OS several times. Tried it also on a brand new RPi3. Tried 3 different USB cables all with the tape mod. Tried two different Ender 3 v2 firmware. The printer is the only thing connected to the USB ports on the RPi3.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20220319104229.zip (137.7 KB)
octoprint (3).log (19.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Creality printers are 1) very susceptible to EMI interference and 2) generators of EMI. This is not a good combination and requires careful shielding and routing of all cables. USB cables need to be short, shielded, and have ferrite beads. Cables connecting the electronics inside the printer may need to be rerouted. Sometimes something as simple as moving the RPi from one side of the printer to the other will help.

Search this forum for EMI and you will find numerous topics with multiple ways this issue has been addressed.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.