Octoprint Disconnects When Bed Temp over 100C - Resolved in Safe Mode

What is the problem?

When heating bed to print ABS above 100C, Octoprint will close the connection to the printer and go off-line. The printer will continue to heat the bed successfully, and will even show "printing" but the toolhead does not move as there is no serial connection.

Serial.log snippet:

021-05-18 03:44:10,460 - Recv: End file list
2021-05-18 03:44:10,461 - Recv: ok
2021-05-18 03:44:12,211 - Recv: T:184.88 /185.00 B:100.00 /100.00 @:47 B@:87
2021-05-18 03:44:12,303 - Connection closed, closing down monitor
2021-05-18 03:44:12,307 - Changing monitoring state from "Operational" to "Offline"

What did you already try to solve it?

Have done multiple restarts of OctoPrint, the Rasberry Pi, the printer and tried every combination of power-up - all have the same result and same issue.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

Yes, it did

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

System bundle attached.
octoprint-systeminfo-20210518034427.zip (948.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Printer: Creality Ender 5 Pro
Motherboard: BTT SKR Mini e3 v2

browser.user_agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36
connectivity.connection_check : 1.1.1.1:53
connectivity.connection_ok : true
connectivity.enabled : true
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1500
env.hardware.ram : 3959701504
env.os.bits : 32
env.os.id : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : true
octoprint.safe_mode : true
octoprint.version : 1.6.1
printer.firmware : Marlin 2.0.8.1 (May 17 2021 21:17:02)
systeminfo.generator : systemapi

There have been reports the latest update of the Thermal Runaway plugin causing this issue.

Edit: But in your case based on the octoprint.log in that system bundle your firmware closed the connection because of a thermal error.

Hmm - if that was the case wouldn't the Printer not work in safe mode either? It is currently printing fine in that mode - I believe the log entries you reference are from earlier yesterday.

Regarding your log, your printer can't even reach 70Β°C:

| Recv: echo:busy: processing
| Recv:  T:219.58 /240.00 B:66.53 /70.00 @:127 B@:127
| Recv: echo:busy: processing
| Recv:  T:218.23 /240.00 B:66.41 /70.00 @:127 B@:127
| Recv: echo:busy: processing
| Recv:  T:216.72 /240.00 B:66.08 /70.00 @:127 B@:127
| Recv: echo:busy: processing
| Recv:  T:215.05 /240.00 B:65.80 /70.00 @:127 B@:127
| Recv: echo:busy: processing
| Recv: Error:Thermal Runaway, system stopped! Heater_ID: bed
| Recv: echo:THERMAL RUNAWAY

How can you print with 100Β°C on the bed?

1 Like

As noted, in Safe Mode I am able to print. The bed is reaching 100C without any issue. I must have configured a plugin (i.e. Thermal Runaway) incorrectly. I will start the process of adding back the plug-ins and reviewing.

There is an issue posted on the Thermal Runaway plugin's github repo and a potential fix available in testing phase.

According your log, the plugin Thermal Runaway is not installed:

|  Access Anywhere - The Spaghetti Detective (1.6.0) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_thespaghettidetective
|  Action Command Notification Support (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/action_command_notification
|  Action Command Prompt Support (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/action_command_prompt
|  Announcement Plugin (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/announcements
|  Anonymous Usage Tracking (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/tracking
|  Application Keys Plugin (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/appkeys
|  Backup & Restore (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/backup
|  Bed Leveling Wizard (0.2.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_bedlevelingwizard
|  Bed Visualizer (1.0.1) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_bedlevelvisualizer
|  Core Wizard (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/corewizard
|  Dashboard (1.17.0) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_dashboard
|  Discovery (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/discovery
|  DisplayLayerProgress Plugin (1.25.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_DisplayLayerProgress
|  Error Tracking (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/errortracking
|  Filament Manager (1.7.2) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_filamentmanager
|  File Check (2021.2.23) (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_file_check
|  Firmware Check (2021.2.4) (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_firmware_check
|  Firmware Updater (1.9.0) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_firmwareupdater
|  GCode Viewer (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/gcodeviewer
|  Logging (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/logging
|  Octolapse (0.4.1) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_octolapse
|  OctoPod Plugin (0.3.0) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_octopod
|  Pi Support Plugin (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/pi_support
|  Plugin Manager (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/pluginmanager
|  Preheat Button (0.6.0) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_preheat
|  PrettyGCode (1.2.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_prettygcode
|  PrintTimeGenius Plugin (2.2.7) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_PrintTimeGenius
|  PrusaSlicer Thumbnails (0.1.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_prusaslicerthumbnails
|  Resource Monitor (0.3.1) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_resource_monitor
|  Software Update (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/softwareupdate
|  Themeify (1.2.2) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_themeify
|  TP-Link Smartplug (0.9.26) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_tplinksmartplug
|  Virtual Printer (bundled) = /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins/virtual_printer

I'm with @Ewald_Ikemann - the printer is struggling to heat up. For whatever reason this is, there is nothing OctoPrint can do to make it heat up better.

You do have intermittent undervoltage issues on the Pi as well, it occasionally reports throttling. My best guess is that something is pulling too much power (maybe the printer) causing voltage drop?? I hope that sounds reasonable to everyone else... It's the best I can think of.

Also, if you find the issue again upload a new serial.log, I can see it is now enabled in the bundle but this doesn't pick up the issue.

2 Likes

Thanks all - I believe I was able to identify the issue. I had the TP-SmartLink plugin configured with Thermal Run Away protection that triggered when the heater bed hit a max temp of 90C. I suspect that when that was triggered a "shutdown" event occurred causing OctoPrint to disconnect. It would not reconnect as the bed was still over the 90C threshold. Thanks everyone for their input. @Charlie_Powell thank you for the insight on the voltage drop - I'll need to look into that.

3 Likes

Well that's good news too I suppose. At least I know my plugin works as intended...lol.

1 Like