Octoprint disconnects when I issue a command

What is the problem?

I got octoprint about 2.5 weeks ago, a couple problems, fixed, and now when I booted it up and tested it by turning the fans on, boom, it says "Printer halted. kill() called!" So I came here

What did you already try to solve it?

Tried restarting both printer and octoprint, tried cycling the micro usb cord. I also tried running other commands, like leveling with the bed visualizer plugin I installed.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20220125112112.zip (26.7 KB)

Additional information about your setup

I'm running Octoprint off of an HP desktop I booted to Ubuntu, I use Jyers BL/CR Touch firmware, and I'm viewing the UI from Firefox.

| Last lines in terminal:
| Recv:  T:17.30 /0.00 B:17.23 /0.00 @:0 B@:0
| Recv:  T:17.25 /0.00 B:17.07 /0.00 @:0 B@:0
| Send: M106 S0
| Recv: ok
| Recv:  T:17.40 /0.00 B:17.32 /0.00 @:0 B@:0
| Send: G91
| Recv: ok
| Send: G28 X0 Y0
| Recv:  T:17.34 /0.00 B:17.25 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
| Recv:  T:17.38 /0.00 B:17.21 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:17.40 /0.00 B:17.29 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:17.38 /0.00 B:17.19 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:17.34 /0.00 B:17.21 /0.00 @:0 B@:0
| Recv: echo:Homing Failed
| Recv: Error:Printer halted. kill() called!

According to your log the issue is actually not issuing a fan command but rather issuing a home command (G28). Your printer then seems to try to execute that and finally gives up because something (which it doesn't further clarify) goes wrong spectacularly and so bad it decides to enter kill state.

Make sure the printer is powered on, that the axes can move freely, that the end stops aren't engaged but DO engage when the head hits them, and that in general your printer is mechanically sound. If that fails, look into the firmware. In general, try printing from your printer's SD card or something like this, make sure THAT works, then try adding OctoPrint to the mix. This is your printer saying something is terribly wrong, not OctoPrint.

Ok, I tried moving the nozzle up, nothing, tried auto homing, nothing. This was all done on the printers LCD, not sure what's wrong.

Nevermind, I plugged the printer into a direct outlet, fixed it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.