Octoprint DNS issue

What is the problem?
I can access the Octopi Interface from any device on my network, phone, iPad, MacBook Pro, Windows 10 laptop's, except for a new MacMini M1 which cannot see the server in Safari or Chrome from the same url or from its IP address. Even pinging the IP address from Terminal gets host unreachable.

What did you already try to solve it?
Restarted the octoprint server and reset network settings on the MacMini M1.

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

What does ip addr show at the console give you?

Ip address shows as

I've got three Windows 10 pcs that can all connect to it via IP address and octopi.local through Chrome, and my MacBook Pro, iphone 12 Pro and iPad Pro can also all connect via both methods through Safari.

My new Mac Mini which was a clone install of my MacBook Pro cannot access it on either octopi.local or through Safari or Chrome browsers.

Bit of a head scratcher.

If the Mac Mini cannot connect to it via its IP address, then the only thing I can think of is that the Mac Mini is on another network than the other computers/tablet/phone you tried. What is the IP address of the Mac Mini?

Mac mini is on the same network.

IP address of It can see the router and ping it successfully.

How about the Mac Mini and the MacBook Pro? Can they see eachother? Can you copy files between them over the network?

The job of resolving DNS names and routing packets in a Local Area Network falls primarily on the router. If WiFi is involved, the the WiFi access point (if different than the router) plays a role as well.

When you say the Mac Mini is a clone of the MacBook Pro, I hope you at least changed its host name.

In any case, there is nothing you can change in OctoPi to resolve this issue (although there are things you could use to help troubleshoot). I'd start with the arp command on OctoPi. The arp command (options / switches may vary) can be used on other systems as well.

Yes they can both see each other and copy files across.

All of the devices are using my D-Link Dir-X5460 routers address for DNS (

Both the Mac mini and the MacBook Pro have unique host names and can see each other on the network and transfer files between them.

To be honest, I might hard reset the Mini and reinstall as a new machine just in case anything has been confused from restoring from a Time Machine backup.

You might want to reboot the RPi as well. I think the ARP tables may be stale. If that doesn't work, reboot the router.

Well I reset the Mini (another story in itself).

Still didn't work.

I've now connected an ethernet cable to the Pi. And now it works, so must be something to do with the wifi.

Thanks for all your assistance :smile: