Octoprint do not run anymore after update to 1.5.0

What is the problem?

After agree to update to 1.5.0 the octoprint service does not start any more.
message on web server is :
"The OctoPrint server is currently not running"

What did you already try to solve it?

i performed some reboot, but still not working
tried manualy (as pi user):
sudo service octoprint restart without success

Have you tried running in safe mode and if so did it solve the issue?

it does not start in safe mode too (modified config.yaml to test safe mode)

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

from log :
2020-12-01 17:24:55,003 - octoprint.environment - INFO - Detected environment is Python 2.7.16 under Linux (linux2). Details:
| hardware:
| cores: 4
| freq: 900.0
| ram: 917020672
| os:
| bits: 32
| id: linux
| platform: linux2
| plugins:
| pi_support:
| model: Raspberry Pi 2 Model B Rev 1.1
| octopi_version: 0.17.0
| throttle_state: '0x0'
| python:
| pip: 19.3.1
| version: 2.7.16
| virtualenv: /home/pi/oprint

When loggin with user pi, i've git this message :

Traceback (most recent call last):
File "", line 1, in
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/init.py", line 6, in
import logging as log
File "/usr/lib/python2.7/logging/init.py", line 26, in
import sys, os, time, cStringIO, traceback, warnings, weakref, collections
EOFError: EOF read where object expected

Access OctoPrint from a web browser on your network by navigating to any of:

So, any clues ?
Thanks for help.

Try a force-reinstall, looks like something might be corrupted. Let's hope that you haven't been pulling the power on it:
~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint

1 Like

Does not work :

pi@octopi:~ $ ~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint
Traceback (most recent call last):
File "/home/pi/oprint/bin/pip", line 6, in
from pip._internal.main import main
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/main.py", line 9, in
import logging
File "/usr/lib/python2.7/logging/init.py", line 26, in
import sys, os, time, cStringIO, traceback, warnings, weakref, collections
ValueError: bad marshal data (unknown type code)

looks like there is some python issue, strange, may be some plugin install broke the python.

Sounds like corruption to me...

Yep, something is seriously corrupted in the virtual environment there. If you are in the habit of just powering off the pi without shutting it down through the system menu first, stop doing that.

This might fix it (but you will have to reinstall your plugins, your settings will persist however):

mv ~/oprint ~/oprint.broken
virtualenv ~/oprint
~/oprint/bin/pip install OctoPrint
sudo service octoprint restart
1 Like

Does not work too, python seems dead :slight_smile:
i will flash a fresh image, should solve the problem.

Thanks for all your help.

virtualenv ~/oprint
Running virtualenv with interpreter /usr/bin/python2
Traceback (most recent call last):
File "/usr/lib/python2.7/encodings/init.py", line 31, in
import codecs
ValueError: bad marshal data (string ref out of range)