Octoprint does not connect via USB

Octoprint does not connect via USB, only works with the printer turned off

What did you already try to solve it?

I used 4 different USB cables
I tried to connect a usb cable without the VCC wire connected
I changed the memory card 2 times
I rewrote the motherboard bootloader
I reinstalled the motherboard operating system (Marlin)
I tried to use clean operating system and install Octoprint manually
I checked all the connectors
I changed the Raspberry's power supply to 5v - 3A

When typing dmesg the following USB error appears:

usb 1-1-port5: connect-debounce failed

Additional information about your setup

Marlin 1.1.7 (This is my original, I don't know if there are any firmware prerequisites to run Octoprint)

Hello @Marzochi!

it seems you built your own printer.
You put of lot of effort into solving.
But can you share the logs?

Usually every firmware version (of Marlin/RepRap/Prusa etc) works as long the firmware has no flaws. But also: the newer the better.

You may also try this:

Does the printer show up at a PC and can you connect to Pronterface?

1 Like

check the user rights for the TTY

sudo usermod -a -G tty pi
sudo usermod -a -G dialout pi

If you did indeed build your own printer, can you tell us what controller (motherboard) you used, please. Also some details on the RPi (or whatever is running OctoPrint) would be useful.