Octoprint does not turn my extruder fan on

What is the problem?

When i start printing a GCODE-file on my Prusa MK3S, the extruder fan stays off the whole time. Settings on PrusaSlicer are configured to keep the fan off the first three layers but then keeping it always on between 40 and 60%

What did you already try to solve it?

Tried to increase power to the fan and also to start the fan on first layer. When i turn on the fan using Printoid manually, the fan works.

Have you tried running in safe mode and if so did it solve the issue?

No

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

See uploaded files
serial.log (148 Bytes) octoprint.log.2020-09-25.log (329.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Prusa Firmware 3.9.1 (September 2020), Octoprint 1.4.2 on Raspberry Pi 4

The fan command(s) are in the GCode file being sent to the printer. They should be M106 commands. You can open the GCode file with an editor and search for them.

You need to turn serial logging on before you start the print so that the serial.log contains something useful. We are going to need this file to help sort out this issue.

Ok, actually printing a file. i will change the seetings and upload a new serial.log tomorrow. The GCODE-file contains M106 commands. Here's an excerpt:

(...)
M106 S127.5
G1 F1800.000
G1 X125.569 Y188.132 E0.05628
M106 S102
G1 F2700.000
G1 X163.632 Y188.132 E1.28840
G1 X163.632 Y112.208 E2.56995
M204 S1000
G1 X163.225 Y112.208 F10800.000
M204 S800
G1 F1500.000
G1 X163.225 Y34.065 E2.64502
M106 S127.5
G1 F1800.000
G1 X163.225 Y32.931 E0.05629
M106 S102
(...)

Here's the latest serial. log: serial.zip (1.3 MB)

The serial.log shows the M106 commands being sent to the printer and the printer responding with ok. OctoPrint appears to be working correctly so the only thing I can think of to try is to use safe mode and see if the problem persists.

Okay, i will give it a try with safe mode. Will report when done.