Octoprint does not work after disabling octoeverywhere

What is the problem?

Octoprint does not work after disabling octoeverywhere and doing required reboot

What did you already try to solve it?

log in via ssh, verified that "ps -ef | grep -i octoprint | grep -i python" is running, what it does not, tried to look into logfile, does not give me permissions to do so ->" -bash: /home/pi/.octoprint/logs/octoprint.log: Permission denied"

Have you tried running in safe mode?

does not even start to safe mode

Did running in safe mode solve the problem?


Systeminfo Bundle

unable to download one :frowning:

Additional information about your setup

OctoPrint version: latest , Anycubic I3 mega, browser: google chrome, operating system: win 10, Plugins: Octolapse, Astroprint, filament sensor reloaded, psu control, touchUI, Simple emergency stop, Mote Lighting control - the system had been running for a goo half year with a rpi 3b

Any ideas ?

try to open the log in a text editor instead :wink:

nano /home/pi/.octoprint/logs/octoprint.log

or download it with WinSCP

Thanks. Now i was able to open the log !
octoprint.log (329.3 KB)

Now any ideas?

Hey! I'm the developer behind OctoEverywhere! I see in your log that there's a bug in the plugin, causing all of these lines:

2022-02-24 19:28:08,282 - octoprint.plugins.octoeverywhere - INFO - Server con wss://starport-v1.octoeverywhere.com/octoclientws[6] IS past it's RunFor time 20 days, 20:46:31.918454 and IS past it's time since last user activity 20 days, 19:29:00.079240

2022-02-24 19:28:08,283 - octoprint.plugins.octoeverywhere - INFO - Server con wss://starport-v1.octoeverywhere.com/octoclientws[6] RunFor is complete and will be disconnected.

But that shouldn't be affecting your system from booting. To me from your log it looks like the most recent boot in safe mode was successful from the logs perspective. How do you connect to your OctoPrint instance? By IP or using the .local hostname? I do see that the zero config system seems to be unhappy

2022-02-24 19:35:16,819 - zeroconf - WARNING - Error with socket 7 (('', 5353))): [Errno 101] Network is unreachable

Traceback (most recent call last):

File "/usr/lib/python3.7/asyncio/selector_events.py", line 987, in sendto

self._sock.sendto(data, addr)

OSError: [Errno 101] Network is unreachable

I connect to it via ip.... but it only booted into safemode once, after restarting from the plugin disabling, but i instantly rebooted as i saw this....:man_facepalming: how do i force it to boot into safemode?

Now i´ve ran ~/oprint/bin/octoprint safemode to boot into safemode, but now it doesnt even show up or wants to connects via ssh..... maybe now reinstall on sd card and then completly fresh setup?

That command (I don't think anyway) doesn't actually boot the server, just sets the flag so that next time it tries to do so. So you would need to restart OctoPrint again following that command.

I did reboot then but now nothing happens anymore

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.