Octoprint doesn't accept my SSH password

What is the problem?

I use a fresh install of octoprint, but if I try to use SSH then it says the default password (raspberry) is wrong.
I never used octoprint before so it isn't unlikely that the solution is very obvious.

What did you already try to solve it?

I flashed Octoprint multible times already. (I also tried to change the default password in the Raspberry pi imager, which didn't help)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Additional information about your setup

Raspberry pi 4B, I used the Octopi image from the raspberry pi imager

Hello @Deus_ex_machina !

Do you have an English type keyboard layout?

SSH on OctoPi usually is setup for English language.

E.g.: With a German keyboard, Y and Z are swapped.

I do have a german keyboard, but that's not the problem. (Since I use ssh that can't really be a problem since the keyboard input goes through windows which knows about the german keyboard.)

Yes, but the SSH input is English and when you type Y the input in SSH is Z.
Try typing raspberrz for the password.

I understood what you meant. I also tried it now, but that wasn't the problem.

While the input is in english, I use the windows terminal for it and windows only sends the letter, not where on the keyboard I pressed. The kind of keyboard that I use shouldn't make a difference.

Every keyboard by default is English coded.
For different countries they put other key caps on it.
But the output is still English.
So you have to localize your OS when you use another input language than English by using the keyboard mapping..

If you use e.g. Putty to connect to a device via SSH, the keyboard mapping is bypassed, because that certain device has an own OS and in case of OctoPi it is set to English localization.

When you press Y it appears to be a Z at OctoPi.

Via SSH you then can set the localisation of OctoPi to German to fit it to your Keyboard.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.