Octoprint doesn't detect printer in USB

Hi everyone ! :slight_smile:

What is the problem?
My Octoprint on Raspberry pi3B+ doesn't detect the serial port of my Ender 3 anymore. It worked during several month without problem and stopped without any modification from my part.

What did you already try to solve it?
What i did to identify the problem :

  • Check the voltage on the raspberry pi : OK (>5v)
  • Change my usb cable to another : Same problem
  • Disable all plugins on Octoprint (safe mode) : Same problem
  • Reinstall Octopi : Same Problem
  • Tested usb port on Raspberry pi (with a usb key) : OK.

To ensure that the raspberry was not powering up the ender 3 I also added a piece of tape on the 5v usb port. I removed it to ensure it was not the problem. This lead me to a strange behavior :
When my printer is not powered ON and my raspberry pi is, I can connect to the serial port (with the tape removed). Then I power ON my printer and the connection stays (however i didn't tested this while printing). If my printer is powered ON before establishing the connection this does not work.
To disable the USB port voltage, I installed a plugin (https://github.com/OutsourcedGuru/OctoPrint-USBControl) but if I disable the 5v on USB after establishing the connection to my printer the connection is lost.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
Logs on Octoprint :

Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: []
Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."
Failed to autodetect serial port, please set it manually.

Logs on raspberry pi (dmesg command) :

 3.319890] usb 1-1.2: new full-speed USB device number 4 using dwc_otg
usb 1-1.2: device descriptor read/64, error -32
usb 1-1.2: device descriptor read/64, error -32

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
Printer : Ender 3, Firmware : Marlin 1.1.8
Raspberry pi 3B+ : Octopi 0.17.0, Octoprint 1.4.0

PS: English is not my native language. I hope I made this clear. Thanks for your reply !

Hello @Gebowunjo!

Have you tried to connect the printer to your PC and checked connectivity with Pronterface? Maybe the issue is on the printer side...

There is exactly the same behavior with pronterface on my computer. I can connect to the printer but only when the printer psu is off (and the 5v from the usb of my computer is powering up the printer).

Also I forgot to mention, but sometimes when I start my printer connected to my raspberry my front fan makes strange noises and is clearly not at full speed. Restarting the printer or reconnecting the raspberry resolve the problem. I don't know if it's related or not. I was going to replace the fan (thinking it was a fan problem).

I guess some fine filament strings are slowing down the fan. You might have to clean it.

I already did that. I changed my fan yesterday and it doesn't do strange things anymore. Meanwhile my main problem stays. I Can't connect to my printer correctly.

So you were right. I did change my printer motherboard and it did correct the problem. At least I changed it for a better version ^^.

1 Like