Octoprint Doesnt Recognize My printer

What is the problem?

Octoprint is giving me 31 different /dev/ttySxx for me to connect to but not one of them works.

What did you already try to solve it?

Restarting, using different Operating Systems to install

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/112.0
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 2900
env.hardware.ram: 8102633472
env.os.bits: 64
env.os.id: linux
env.os.platform: linux
env.python.pip: 23.1.2
env.python.version: 3.10.6
env.python.virtualenv: true
octoprint.last_safe_mode.date: 2023-05-01T05:39:17Z
octoprint.last_safe_mode.reason: incomplete_startup
octoprint.safe_mode: true
octoprint.version: 1.8.7
systeminfo.generated: 2023-05-01T06:13:41Z
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am running OctoPrint on Linux Ubuntu Distro

Octoprint Version 1.8.7

Tried 3 different cables

Also when starting my Ender 3 v2 it plugging in the pc to the printer makes the UI on the printer unreadable.

let's try a solution to a common issue with ubuntu:
Run this in the terminal and reboot the machine afterwards sudo apt -y remove brltty.
It removes the brltty package which claims the usb connection when it's running.

1 Like

Do you have any entries in the 'additional serial ports' list? /dev/tty* is not normally a printer, and OctoPrint doesn't list them by default as far as I know. Normally a printer would be on /dev/ttyUSB0 for example.

1 Like

It tells me it is unable to locate package brltty

So Im a complete noob at 3d printing and I was following a guide on how to install klipper and fluidd with octoprint...

Not sure how to even get back to the installation of moonraker, fluidd, and klipper but those are some of the things I have installed and may be what the hiccup is?

Have you reinstalled Marlin to the printer?

1 Like

I installed new firmware when I got a new motherboard. I have the 4.2.7 board now. So probably updated 3days ago

Can you please share the systeminfo bundle?

1 Like

Yes, and thank you so much for all your help! I really appreciate it.

octoprint-systeminfo-20230501133800.zip (32.1 KB)

According to the octoprint.log it appears, that the printer contains Klipper firmware.

1 Like

Brand new ender 3 v2. I think it might be because I followed a tutorial on how to install octoprint and it installed klipper, moonsail, moonraker and fluidd. I don't know how to uninstall them lol. I didn't have the printer at the time. I'm brand new and thought it was something I was supposed to install.

For the OctoPrint installation seems to be clean, you 'only' have to upload a Marlin firmware file appropriate to the board and printer.

You may start here:

Ok cool I'm gonna try this and get back to you!! Thanks again!

1 Like

So Here is my current firmware that I'm working with. It is from the creality website. I have a Cr Touch on installed on my printer.

I'm not sure which one from Marlin that I can update with because in the examples folder from Marlin's github it only gives me 3 different board which none of them that I have (I have 4.2.7)


@Emberlynn, While many of the members of this community are excellent resources, I don't believe any of them are omnipotent. I would strongly suggest that you open your own Get Help topic and fill in the template with YOUR information so we can provide the personalized help you expect.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.