Octoprint doesnt see /tmp/printer in virtualbox setup


#1

I have octoprint/klipper installed in debian in virtualbox on my windoze 7 x64 tower.

Services for klipper/octoprint status is success. octoprint can connect to ttyUSB0 (usb2), but it cant see /tmp/printer which I did setup in octoprint.

I reinstalled it all twice.

Debian sees /dev/ttyUSB0

I cannot get avrdude to upload the firmware to my Tronxy X5S Melzi board which does not have a bootloader.
I then installed arduino Ide, and added sanguino board, as in Tronxy X5S forum a guy has a USB/arduino only solution for this board which works super amazingly easy. But to do that i need a configuration.h file plus the rest,I dont know how to make ardiuno ide upload the hex file only.


#2

I was reading installtion.md and see that klipper is supposed to put info into /tmp/klippy.log but it does not create such a log file, so...stumped.


#3

Did you ensure the user in the virtualbox is setup for access to the tty and dialout?

sudo usermod -a -G tty pi
sudo usermod -a -G dialout pi


#4

It is interesting that you ask this question WarHawk. Klipper originally would not start, user issue, so i put my username in the places where pi was, and then klipper would start. I also ran those commands but with my username not pi.


#5

Search for "marlintool" It is a script that loads the arduino ide, marlin source, compiles and uploads...


#6

I have octoprint working just fine, but the idea is to make use of Klipper, so i suppose I must ask at a klipper forum.


#7

General rule of thumb: OctoPrint can only see ports that it a) knows to look for and that are b) also seen by the underlying OS.

So for OctoPrint to see /tmp/printer that needs to be added to its additional ports (it isn't part of the default set) and that port also needs to actually exist (ls /tmp/printer shows something).

I understand you've taken care of the former, the latter is what's missing, and that's probably something fairly klipper specific that a klipper focused community might indeed be better able to resolve.

Still, once you figure it out it would be nice if you'd post here what the issue was.


#8

UPDATE: A certain gent took the time to help me through this issue.
It turned out to be 2 things.

  1. The klipper-env environment was running the executables, and I did not know that.
  2. The klipper file in /etc/default was seriously messed up.
    All three lines had issues. In the end I removed all the programming headings in {}, and manually inputted the full paths to the folders.There were references here to klipper-env which I changed to klipper.
    After a restart of klipper service,then only the /tmp/printer file appeared, and the klippy.log was getting data.

At that time it was discovered that klippy could not connect to the serial port.
This problem was caused by incorrect baud rate selected with make menuconfig. In my case my com port is 115200, So, with that change make was done.
The last hurdle was the meltzi board not having a boot loader.
I was definately not looking forward to further research to find out how to program a bootloader, when this kind gent supplied me with an avrdude cmline string, which just smashed through that hurdle, and the firmware was loaded onto the board.

I am now printing on my tronxy X5S in x86 Raspbian in Virtualbox on my Windoze 7 Tower.
Neat, hey?

Just as a note of interest.
The install-octopi.sh initially gave me much gried, it failed with the pyserial line,plus two other packages,green something.
I used apt to get the latest versions of these three packages, and then the install file worked.


#9

I've never heard of that file and it sounds like it might be wrongly named (OctoPi is the image, OctoPrint is the server) :thinking: Where do I find that file?


#10

Inside that file, the first line: This script installs Klipper on a Raspberry Pi machine running the
OctoPi distribution.

I started with this after installing the raspian x86 iso into virtualbox: (http://www.aoakley.com/articles/2017-07-04-raspbian-x86-virtualbox.php)
https://github.com/KevinOConnor/klipper/blob/master/docs/Installation.md
which has:
git clone https://github.com/KevinOConnor/klipper
./klipper/scripts/install-octopi.sh
At this point it failed-the script had files that would not install.
I mentioned I did a apt-get for the latest versions because the script is very specific about the exact version it wants, but that was not working for me, most likely because I was installing onto X86 raspbian,lol.

I then also did the octoprint download from your site, and still no go,and here it gets hazy, because I am definately NOT applying a scientific approach.
I kept repeating install-octopi.sh and downloading octoprint,and klipper, and deleting all those folders once as well, and repeating everything I have mentioned here, and apt-get all the latest files I found in that file(install-octopi.sh) and I must have done something right, because I then found that install-octopi.sh worked, and KLIPPER was up and running, and i just needed help with the /etc/default/klipper file having issues with the "{}" not working,I dont know why, so i just manually pointed to the correct locations,and then finally klipper began working with Octoprint .


#11

Ah! So it is named like that because it's supposed to install klipper on OctoPi, gotcha.


#12

Hi guys, sorry to bring this thread up again, I've been trying to fiddle with this for hours and still can't get it to work.

I'm having the same issue of /tmp/printers not showing up on the list of serial ports to select, and I'm at my wits end. Would appreciate if I could get some help!

I'm running it on an Orangepi with the latest version of Armbian and Octoprint installed.

Thanks!


#13

Perhaps @XL777 is your best bet since he's one of the few who have done this.