OctoPrint doesn't show a temperature graph for my Creality printer with stock firmware

In theory, the TP Link plugin should be fine because the double temp fix plugin does the parsing of the temperatures with some special workarounds, that are then available to everything else (such as the temp graph, plugins etc.).

I haven't received a report of it effecting my plugin once the temp fix plugin is installed, but that could just mean noone is using the combination yet. Easiest way to try would be to set the threshold low while not printing and then just set the temp higher than that value.

Ok so My printer (Ender 5 Pro) shows the double display in the terminal window and I get the "broken FW warning" but if it weren't for the warning i would never know that there was a problem. OctoPrint has no issue parsing out the various temperatures and everything displays correctly outside of the terminal window.

Only reason i would consider the fix would be to get rid of the warning. When I go to the "fix" link i can't seem to figure out how to install it, I use the command line given all I get is "pip is not a valid command" Is there anyway to just get rid of the warning or help installing the fix so the warning goes away?

You can install the plugin from the plugin manager, just like any other plugin. The warning only shows if it detects issues, if you think there is something wrong with the warning please post with full logs etc. To clarify, I believe this issue does not occur all the time with this firmware, and it may only be during idle. Full serial logs will confirm if you still have this issue. OctoPrint definitely cannot parse the double temperature reporting, and requires the plugin to do so.

I have just installed a Ender 3 Pro and I get the broken firmware message. I installed the Creality 2x temperature reporting fix through the plugin manager but still get the same warning.

I contacted Crealty and they asked me to TRY to update the firmware with a file they made available. I havent tried it yet as I'm not sure if I should (dont know how to do it as well).

Could you guys give me a hand? I need this to work.

Thanks.

It looks like you may have installed the 'wrong' Creality Temperature plugin. The one you want is here:

For reference, it looks like the one you installed is this one: Creality Temperature Fix

That was easy! Thanks Charlie.

This is what happened, I searched for "Creality temperature fix" in the plugin manager and the result was the wrong plugin showing up. I got that name from the plugin page right corner (attached image).

Irony: Feels terrible when you make a stupid mistake...but it feels great to know that you didn't actually have a problem after all... :laughing:

1 Like