Octoprint Dropping set tempreture

so, my ultimaker has developed an issue, but i think its related to octoprint. the screen is dead so ive been using the set temps to do filament changes and preheat etc, but recently if i select a preheat temp and tell it to go it appears for a split second on the graph as target temp before disappearing, the hotend will start to heat and increase slightly in temperature. if i keep nudging every time it drops out it will heat, but not ideal. if i send an m109 s190 command it will heat and stays till it reaches the target overshoots and then just doesn't maintain it. M104 drop off instantly again. help?

What did you already try to solve it?

Run in safe mode, tried terminal codes

Have you tried running in safe mode?


Did running in safe mode solve the problem


System Bundle Information

octoprint-systeminfo-20210907113050.zip (46.6 KB)

Additional Info

Version 1.6.1
Version 0.17.0, running on Raspberry Pi 3 Model B Rev 1.2
ultimaker 2running Tinker

Hello @mally110 !

So could you please also fill in the rest:

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


hope this helps


overshooting and then dropping - did you try PID autotune already?

serial.log might really be useful here to follow the communication between octoPrint and your printer. However, serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
Please do and then go through all the steps you describe above to get them logged.
Then upload the serial.log here.

ahh sorry, ive explained badly. it doesnt overshoot by alot just the usual couple of degrees, i mean that it then doesnt maintain the temp like it should. it just stops heating, but i can only get it to do this once after restarting octoprint. after its done this if i try and set it to a temp manually it says set the hot end starts to heat then after 1second it drops off and says off. it starts to increase in temp and starts to register on the graph but then just turns itself off. if i try print an object though, it has no issues and completes fine