Octoprint Error printing x3g

What is the problem?

Makerbot flavour files x3g work without issue when transfered to (Makerbot) printer.
But when uploaded to Octoprint and "executed" the process throws an error after a few seconds.
Seems Octoprint has an issue with this apparantly binary format.

Updloading gcode and using GPX plugin works (but there the steps/mm setting seems to be ignored) and prints are scaled incorrectly

What did you already try to solve it?

tried "old" .s3g - same issue

Have you tried running in safe mode?



2021-01-26 15:15:41,436 - octoprint.printer.standard.job - INFO - Print job started - origin: local, path: testcube02.x3g, owner: ma, user: ma
2021-01-26 15:15:41,541 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2021-01-26 15:15:41,610 - octoprint.util.comm - INFO - Changing monitoring state from "Starting" to "Printing"
2021-01-26 15:15:43,319 - octoprint.util.comm - ERROR - Something crashed inside the serial connection loop, please report this in OctoPrint's bug tracker:
Traceback (most recent call last):
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 2400, in _monitor
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 3074, in _handle_ok
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 3299, in _continue_sending
elif job_active and self._send_from_job():
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 3944, in _send_from_job
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 4236, in _sendCommand
process(cmd, cmd_type, gcode, subcode, on_sent=on_sent, tags=tags)
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 4195, in process
self._process_atcommand_phase("queuing", cmd, tags=tags)
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 4616, in process_atcommand_phase
handler = getattr(self, "atcommand{}
{}".format(atcommand, phase), None)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 13-14: ordinal not in range(128)
2021-01-26 15:15:43,346 - octoprint.util.comm - INFO - Changing monitoring state from "Printing" to "Offline (Error: See octoprint.log for details)"

Additional information about your setup

OctoPrint : 1.5.3
File Check Plugin : 2020.8.7
Firmware Check Plugin : 2020.9.23
GPX Plugin : 2.6.8