Octoprint failed to update, then it won boot

What is the problem?
I have octopi running and saw a notice about new version. When I was done printing, I opened settings and procced to update. The update failed. I dig all information regarding the failure. I was thinking into rebooting and try again. But now I got a web page that said that is not running. I check with ps and it is not listed. I tries using service status and shows that is active.

What did you already try to solve it?
Just tried to reboot octoprint and then reboot the raspberry pi.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

octoprint.plugins.tracking - INFO - Sent tracking event startup, payload: {'python': '2.7.13', 'ram': 918200320, 'octopi_version': '0.15.1', 'version': u'1.3.10', 'pip': '18.0', 'cores': 4, 'freq': 900.0, 'pi_model': 'Raspberry Pi 2 Model B Rev 1.1', 'os': 'linux'}

My printer is an Anet A8

I have installed the following plugins: Octolapse (not workin properly), telegram, preheat, touch test

system response to Checks if it was running:
Octoprint update windows output:
Octoprint log:
Note: there is no log entries about the system trying to reboot in the log
Plugin software update log:

I am not stressed out. As I said, I did the update after printing what I needed. I am submitting all this information because I am really happy with octoprint and probably this may be useful for the team.
I have back up of my printer setting, so I can start fresh in any moment. I have ssh to the raspberry pi, so I can get anyfile that I may need. I even was thinking to give it a try to install in a small board computer (jaguard board) that I have gathering dust on a shelf.
I am not deleting my current installation and settings in the upcoming week, so if there is something else that may be useful to improve octoprint, I will gladly try to provide whatever information I can.

Best regards

2019-05-24 04:22:52,787 > netifaces.c:1:0: internal compiler error: Segmentation fault

So, for some reason stuff really fell on its face while trying to upgrade a third party dependency. And due to a segmentation fault (read: a crash) of the compiler on your system. Usually that stuff doesn't just segfault out of the blue, especially not when the very same third party dependency compiles and works flawlessly on other systems.

Based on past reports my money here would be on a corrupted file system having broken something somewhere. Have you ever just pulled power to the Pi without shutting it down properly first? How old is the image and the SD card it's on? It could be dying...

I am a bit lost trying to find something similar to my problem, but this thread is close. I installed Octoprint on a Raspberry P1 3+ for my Ender 5 Printer; and it worked fine for about 1/3 of my 1st small print, then the 3D Print stopped, and the Ender 5 asked if wanted to resume - which failed. While I had the 3D Print running; I successfully logged in (within my home wifi network) with my laptop, then successfully a tablet with the OctoRemote App; but all stopped when I tired to log in on 3rd device .... my smartphone, using OctoRemote App. Since that unexpected HALT; I have not been able to log into the Octoprint over wifi with anything. While I can log into the Pi from a keyboard/monitor terminal set up; my laptop wifi attempt to connect Octoprint offers a Log-in screen, which fails to open with the username/password that I used for all other successful attempts. What am I doing wrong.

Thanks very much for your comments.

The last image that I have in my computer is 2018-04-18-octopi-stretch-lite-0.15.1 with dates from May 2018. So, the system has been running on and off for at least one year. I usually power off the raspberry pi when is not in use.

I usually have a UPS for the 3D printer, but it failed some time ago. I have not been printing regularly, so I haven't replaced it. The system has got a two or three power failures. Luckily it has been when the printer is warming up. It is very possible for the files microSD card to be corrupted or even the card itself to be damage or failing due aging.

As I said, I submitted the information just in case there was something useful for the developing team.

Again, thanks very much for your thoughtful and thorough reply to my message.


You need to check the IP address the Pi currently has, and depending on your OS/browser choices you may not be able to connect to it via octopi.local, but should use the IP address.

If you're sure the IP is correct, get the octoprint.log for us. Considering you can't access it except direct (attached keyboard/monitor), a literal screenshot will suffice if you can't transfer the text.


I gave up and created a new image to test. Everything works OK again, but I am wondering how long.

How do I implement the built-in HTTPS, mentioned at the end of the install ???

I'd wait to use HTTPS- or anything else, like trying to access it remotely- until you are comfortable using it and feel like you can trust it to start consistently.

Thx .... I am trying again with a fresh install, but less toys at the moment.

Is there a Guide somewhere that explains the various settings on each page ???

You mean like the documentation?

User level Documentation this is not ... https://docs.octoprint.org/en/master/index.html
But the work here is impressive.