Octoprint failed update 1.9.0

hi i did an update in octoprint, but it failed and the server dont start after that, i can ssh to my pi, need help to restore it, i also have slicer files i want to recover.

as looking in the logs it was 1.9.0 version and and then it failed.

Kindly Visseb

Would you mind sharing the logs with us?
My crystal ball got bad reception today :wink:


octoprint.log (444.9 KB)

hope this one gets better reception to your crystal ball :wink:

then i tried to acces gui again, and got this.
octoprint.log (5.1 KB)

then i restarted the pi, and this came up, as for the first time it did.

octoprint.log (444.9 KB)

these commands dont do anything for me.

the bigger logfile only shows data until 2023-05-23 and the small file is from today, but doesn't contain anything useful. It stops when the server starts.

If you haven't tried safe mode yet please try it.
Also please try to get the systeminfo bundle in ssh with ~/oprint/bin/octoprint systeminfo . (the dot is important)
You can download the zip for example with WinSCP.

thanks! will try that, yeah i manage to download the zip files.

will try safe mode or try an clear install.

1 Like

Did you ever get this working? I went to log into octoprint today and was also greeted with this warning:

i can login over SSH but i honestly have no idea what im looking for but when i copy/paste any of the messages in the error nothing seems to work:

login as: pi
pi@'s password:
Linux octopi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Jun 13 19:30:16 2023 from

Access OctoPrint from a web browser on your network by navigating to any of:


https is also available, with a self-signed certificate.
This image comes without a desktop environment installed because it's not
required for running OctoPrint. If you want a desktop environment you can
install it via

    sudo /home/pi/scripts/install-desktop
OctoPrint version : 1.9.0
OctoPi version    : 0.18.0

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi@octopi:~ $ ~/.octoprint/logs/octoprint.log
-bash: /home/pi/.octoprint/logs/octoprint.log: Permission denied
pi@octopi:~ $

nope, trying to reinstall to 1.9.1 but it tells me to update pip, and i didnt get that to work out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.