OctoPrint fails and breaks OS

What is the problem?

I have installed OctoPrint on a Raspberry Pi 4B, twice, for my Creality Ender 3 v2.

First, i used the guide at Setting up OctoPrint on a Raspberry Pi running Raspbian or Raspberry Pi OS. Having done the initial setup of the RPi, I did all the Python and venv setup. I installed two Creality fixes (Creality 2x temperature reporting fix and Creality Temperature Fix), plus BLTouch. I successfully printed one object, but then when I started to print another, I got a 500 error on the UI.

More interesting, the OS was messed up. When I logged in to the RPi directly, I couldn't even do "ps": responded "-bash: ps: command not found" The same for anything else I tried to do.

What did you already try to solve it?

Thinking it might be the venv style or something, I found another guide (https://all3dp.com/2/octoprint-setup-how-to-install-octopi-on-a-raspberry-pi/) and installed octopi using the RPi imager. I added the three plugins again, but then got the 500 error in the GUI. The OS is again messed up. "echo $PATH" shows a reasonable path, which includes /usr/bin. When I execute /usr/bin/ps I get "-bash: /usr/bin/ps: Input/output error"

Have you tried running in safe mode?

I can't run in safe mode, since the GUI is broken.

Systeminfo Bundle

I can't get this either.


I'm not sure what version I tried first. The second time, I installed OctoPi 0.18.0 with OctoPrint 1.7.2.

Hello @rickw !

Is there a need for installing OctoPrint onto an existing OS and not using OctoPi?

Instead of the systeminfo bundle (since that will require octoprint running to download), try just getting the octoprint.log. You can find it on the filesystem at ~/.octoprint/logs/octoprint.log.

It might not be OctoPrint causing the issue, but it's 500 error might be another symptom of the same issue. Is the SD card you are using good? Not corrupted or old?

I tried both, they both failed the same way.

Then I assume there is either something wrong with the SD card or the Pi.
I have two OctoPi installations running without problem.

I think the SD card is probably good, in fact I just did a print direct from the Ender control panel.

Some new information: I logged in to the RPi to try to get the octoprint.log, as Charlie suggested, and was able to work normally.

The shell was now working, so I tried opening the GUI, and it opened. The log bundle is here:

octoprint-systeminfo-20211218191058.zip (34.0 KB)

I did all this with the RPi disconnected from the printer. So of course, I had to try OctoPrint again, and it did one print perfectly. I'm totally confused, but I did order a couple of new SD cards, since Ewald and Charlie both suggested SD card problem. This one is only a about a week old: I got it to flash the Ender firmware for the BLTouch, but who knows?

We are both meaning the SD card that is in your Pi running OctoPrint, not the one in the printer.

We are both meaning the SD card that is in your Pi running OctoPrint, not the one in the printer

Thanks for the clarification. I'm not using an SD card in the Pi: I built it directly on a USB thumb drive: this is my normal practice: I have three other Pi 4s running 24/7 that way.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.